Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1876454 - NRPE start bofore network is online
Summary: NRPE start bofore network is online
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: nrpe
Version: epel7
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Martin Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-07 09:09 UTC by Uwe Müssel
Modified: 2020-09-23 16:35 UTC (History)
7 users (show)

Fixed In Version: nrpe-4.0.3-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-23 16:35:08 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Uwe Müssel 2020-09-07 09:09:09 UTC
Description of problem:
NRPE starts after network.target is reahced. When configured with bind ip, it may fail because of unconfigured ip.


Version-Release number of selected component (if applicable):
RHEL 7.8
nrpe-4.0.3-1.el7.x86_64

How reproducible:
Problem depens on timeing at startup. So it cannot be reliably reproduced.

Steps to Reproduce:
1. Configure server_address in /etc/nagios/nrpe.conf
2. Reboot system

Actual results:
Sep  4 19:01:42 lterm2001 nrpe[925]: Starting up daemon
Sep  4 19:01:42 lterm2001 nrpe[925]: Bind to port 5666 on 10.6.250.225 failed: Cannot assign requested address.


Expected results:
NRPE daemon should start without error

Additional info:
Systemd service file contains:
Requires: network-online.target
it should contain:
After: network-online.target

Comment 1 Martin Jackson 2020-09-07 16:10:31 UTC
Please try the build for EPEL7 at https://copr.fedorainfracloud.org/coprs/mhjacks/nagios-packages/ if you can and let me know if this fixes it.  Apparently the old config (Requaires= but not After= is racy).  If this works for you I'll update the branches and get this into the stable pipeline.

Comment 2 Uwe Müssel 2020-09-08 06:33:17 UTC
Hello Martin,

thanks for your quick reply. I've tested the new package. I seems to solve our problem:

$ systemd-analyze critical-chain  nrpe.service
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

nrpe.service @4.043s
└─network-online.target @4.041s
  └─network.target @4.038s
    └─NetworkManager.service @2.995s +121ms

Comment 3 Fedora Update System 2020-09-08 14:43:22 UTC
FEDORA-EPEL-2020-67a5e75fa9 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-67a5e75fa9

Comment 4 Fedora Update System 2020-09-09 14:42:55 UTC
FEDORA-EPEL-2020-67a5e75fa9 has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-67a5e75fa9

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2020-09-23 16:35:08 UTC
FEDORA-EPEL-2020-67a5e75fa9 has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.