Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1880159 - Boot Options doesn't work
Summary: Boot Options doesn't work
Keywords:
Status: CLOSED DUPLICATE of bug 1856399
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-17 19:42 UTC by Alessio
Modified: 2020-10-18 09:09 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-18 09:09:34 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Alessio 2020-09-17 19:42:59 UTC
Power Off/Log Out -> Restart
Press Alt, the "Restart" button become "Boot Options"
Click
At this point, at reboot, GRUB menu should appear, but it doesn't.

Issuing
sudo grub2-editenv - set menu_show_once=1
GRUB menu appears.

https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/thread/FOV46IVOPAPIVKZCSDARVSWZ2HVWBYG6/

Someone reported that it works as expected on a system upgraded from F32 to F33

Upstream:
https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/199#note_913636

Comment 1 Chris Murphy 2020-09-17 19:57:09 UTC
Choosing "Boot Options" results in boot menu appearing following reboot on baremetal; but not in a qemu-kvm (virt-manager), grub menu remains hidden.

grub2-efi-x64-2.04-31.fc33.x86_64
gnome-shell-3.38.0-1.fc33.x86_64

Comment 2 Alessio 2020-09-17 20:26:52 UTC
(In reply to Chris Murphy from comment #1)
> Choosing "Boot Options" results in boot menu appearing following reboot on
> baremetal; but not in a qemu-kvm (virt-manager), grub menu remains hidden.

For me, it doesn't appear even on baremetal (Dell XPS 13 9360).

Comment 3 Hans de Goede 2020-10-16 13:10:46 UTC
This is likely caused by an selinux issue, see bug 1856399, which I filed quite some time ago, but which is not seeing any progess :| 

Can you try running:

sudo setenforce off

Before trying the "boot options" option ?

If that fixes things, then this is indeed caused by bug 1856399.

Comment 4 Chris Murphy 2020-10-18 05:37:29 UTC
Works following 'sudo setenforce 0' bu 'enforcing=0' doesn't always work which is kinda odd.

Comment 5 Hans de Goede 2020-10-18 09:09:34 UTC
(In reply to Chris Murphy from comment #4)
> Works following 'sudo setenforce 0'

Ok. Lets mark this as a duplicate of the selinux bug then. And thank you for providing the logs in the selinux bug.

*** This bug has been marked as a duplicate of bug 1856399 ***


Note You need to log in before you can comment on or make changes to this bug.