Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1881472 - ValueError: Size limit for minimal size cannot be greater than current maximum size.
Summary: ValueError: Size limit for minimal size cannot be greater than current maximu...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: blivet-gui
Version: 33
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vojtech Trefny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:aed19a986b29b9b368024e3dc75...
: 1870046 (view as bug list)
Depends On:
Blocks: F33BetaFreezeException F33FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2020-09-22 13:29 UTC by Kamil Páral
Modified: 2020-10-02 00:34 UTC (History)
14 users (show)

Fixed In Version: blivet-gui-2.2.1-1.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-02 00:34:48 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: anaconda-tb (1.41 MB, text/plain)
2020-09-22 13:30 UTC, Kamil Páral
no flags Details
File: anaconda.log (24.17 KB, text/plain)
2020-09-22 13:30 UTC, Kamil Páral
no flags Details
File: dbus.log (2.63 KB, text/plain)
2020-09-22 13:30 UTC, Kamil Páral
no flags Details
File: dnf.librepo.log (3.88 KB, text/plain)
2020-09-22 13:30 UTC, Kamil Páral
no flags Details
File: environ (637 bytes, text/plain)
2020-09-22 13:30 UTC, Kamil Páral
no flags Details
File: lorax-packages.log (24.34 KB, text/plain)
2020-09-22 13:30 UTC, Kamil Páral
no flags Details
File: lsblk_output (2.13 KB, text/plain)
2020-09-22 13:30 UTC, Kamil Páral
no flags Details
File: nmcli_dev_list (1.60 KB, text/plain)
2020-09-22 13:30 UTC, Kamil Páral
no flags Details
File: os_info (730 bytes, text/plain)
2020-09-22 13:30 UTC, Kamil Páral
no flags Details
File: program.log (8.91 KB, text/plain)
2020-09-22 13:30 UTC, Kamil Páral
no flags Details
File: storage.log (274.71 KB, text/plain)
2020-09-22 13:30 UTC, Kamil Páral
no flags Details
File: syslog (816.75 KB, text/plain)
2020-09-22 13:30 UTC, Kamil Páral
no flags Details
File: packaging.log (14.73 KB, text/plain)
2020-09-22 13:30 UTC, Kamil Páral
no flags Details
bug demonstration video (400.65 KB, application/x-matroska)
2020-09-22 13:39 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2020-09-22 13:29:57 UTC
Description of problem:
I wanted to create a new partition in Blivet partitioning screen. I selected BIOS Boot partition type, but then changed the value of the field to btrfs. Then anaconda crashed.

Version-Release number of selected component:
anaconda-33.25.2

The following was filed automatically by anaconda:
anaconda 33.25.2 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.9/site-packages/blivetgui/dialogs/size_chooser.py", line 145, in min_size_limit
    raise ValueError("Size limit for minimal size cannot be greater than current maximum size.")
  File "/usr/lib/python3.9/site-packages/blivetgui/dialogs/add_dialog.py", line 816, in on_filesystems_combo_changed
    self.size_area.min_size_limit = self._get_min_size_limit()
ValueError: Size limit for minimal size cannot be greater than current maximum size.

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-E-dvd-x86_64-33 quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
hawkey.log:     INFO Sep-22 13:07:57 === Started libdnf-0.48.0 ===
kernel:         5.8.6-301.fc33.x86_64
product:        Fedora
release:        Fedora release 33 (Thirty Three)
release_type:   pre-release
type:           anaconda
version:        33

Comment 1 Kamil Páral 2020-09-22 13:30:05 UTC
Created attachment 1715704 [details]
File: anaconda-tb

Comment 2 Kamil Páral 2020-09-22 13:30:08 UTC
Created attachment 1715705 [details]
File: anaconda.log

Comment 3 Kamil Páral 2020-09-22 13:30:10 UTC
Created attachment 1715706 [details]
File: dbus.log

Comment 4 Kamil Páral 2020-09-22 13:30:12 UTC
Created attachment 1715707 [details]
File: dnf.librepo.log

Comment 5 Kamil Páral 2020-09-22 13:30:14 UTC
Created attachment 1715708 [details]
File: environ

Comment 6 Kamil Páral 2020-09-22 13:30:16 UTC
Created attachment 1715709 [details]
File: lorax-packages.log

Comment 7 Kamil Páral 2020-09-22 13:30:17 UTC
Created attachment 1715710 [details]
File: lsblk_output

Comment 8 Kamil Páral 2020-09-22 13:30:19 UTC
Created attachment 1715711 [details]
File: nmcli_dev_list

Comment 9 Kamil Páral 2020-09-22 13:30:21 UTC
Created attachment 1715712 [details]
File: os_info

Comment 10 Kamil Páral 2020-09-22 13:30:23 UTC
Created attachment 1715713 [details]
File: program.log

Comment 11 Kamil Páral 2020-09-22 13:30:26 UTC
Created attachment 1715714 [details]
File: storage.log

Comment 12 Kamil Páral 2020-09-22 13:30:30 UTC
Created attachment 1715715 [details]
File: syslog

Comment 13 Kamil Páral 2020-09-22 13:30:32 UTC
Created attachment 1715716 [details]
File: packaging.log

Comment 14 Kamil Páral 2020-09-22 13:38:55 UTC
I can easily reproduce this even with latest Fedora-Everything-netinst-x86_64-33-20200921.n.0.iso:

1. Enter Blivet
2. Click Add partition (you need to have space - start with an empty disk or delete all partitions)
3. Select BIOS boot
4. Select btrfs or ext4 (or probably anything else) 
5. Crash

Comment 15 Kamil Páral 2020-09-22 13:39:23 UTC
Created attachment 1715718 [details]
bug demonstration video

Comment 16 Kamil Páral 2020-09-22 13:43:36 UTC
Proposing as a Beta or a Final blocker:
"When using both the installer-native and the blivet-gui-based custom partitioning flow, the installer must be able to: 
Create mount points backed by ext4 partitions, LVM volumes or btrfs volumes, or software RAID arrays at RAID levels 0, 1 and 5 containing ext4 partitions"
https://fedoraproject.org/wiki/Fedora_33_Beta_Release_Criteria#Custom_partitioning
"The installer must be able to create and install to any workable partition layout using any file system and/or container format combination offered in a default installer configuration. "
https://fedoraproject.org/wiki/Fedora_33_Final_Release_Criteria#Disk_layouts

The installer *is* probably able to create a workable layout, but you must avoid very trivial actions like changing target filesystem values too much, otherwise it crashes. IOW, you're stepping on a mine field.

Comment 17 Kamil Páral 2020-09-22 19:18:41 UTC
I tried to find more ways to trigger this and I didn't. The workaround seems to be: "If you selected BIOS Boot as the partition format and you want to select a different value, cancel the dialog and open it again, then select the new value. Otherwise the installer will crash (when the field is changed to BIOS Boot to something different)."

Comment 18 Kamil Páral 2020-09-23 08:40:23 UTC
Accepted as a Beta freeze exception and a Final blocker:
https://pagure.io/fedora-qa/blocker-review/issue/117

But it's still proposed as a Beta blocker, and with our current system we can't really mark that in Bugzilla, so I'll leave both blockers in the proposed state, until the Beta blocker vote is resolved.

Comment 19 Vojtech Trefny 2020-09-23 09:53:15 UTC
*** Bug 1870046 has been marked as a duplicate of this bug. ***

Comment 21 Kamil Páral 2020-09-23 12:33:24 UTC
(In reply to Vojtech Trefny from comment #20)
> updates image: https://vtrefny.fedorapeople.org/img/rhbz1881472.img

It seems to fix this actual issue, but introduces bug 1881932

Comment 22 Vojtech Trefny 2020-09-23 12:40:50 UTC
(In reply to Kamil Páral from comment #21)
> (In reply to Vojtech Trefny from comment #20)
> > updates image: https://vtrefny.fedorapeople.org/img/rhbz1881472.img
> 
> It seems to fix this actual issue, but introduces bug 1881932

That one is already tracked here https://bugzilla.redhat.com/show_bug.cgi?id=1881932 The updates image contains latest version of blivet-gui (which is currently in testing for F33) + the patch so the change that broke the resize is also in it.

Comment 23 Kamil Páral 2020-09-24 16:33:37 UTC
Rejected as a Beta blocker, so setting as accepted for Final:
https://pagure.io/fedora-qa/blocker-review/issue/117

Comment 24 Fedora Update System 2020-09-29 11:23:29 UTC
FEDORA-2020-f9ad33acdd has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-f9ad33acdd

Comment 25 Kamil Páral 2020-09-29 14:50:12 UTC
(In reply to Fedora Update System from comment #24)
> FEDORA-2020-f9ad33acdd has been submitted as an update to Fedora 33.
> https://bodhi.fedoraproject.org/updates/FEDORA-2020-f9ad33acdd

Fixes the bug.

Comment 26 Fedora Update System 2020-09-30 01:10:23 UTC
FEDORA-2020-f9ad33acdd has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-f9ad33acdd`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-f9ad33acdd

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 27 Fedora Update System 2020-10-02 00:34:48 UTC
FEDORA-2020-f9ad33acdd has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.