Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1883431 - Not detecting USB headset unless daemon is restarted
Summary: Not detecting USB headset unless daemon is restarted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 32
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-29 08:23 UTC by Yajo
Modified: 2020-10-01 01:29 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-01 01:29:00 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Yajo 2020-09-29 08:23:08 UTC
Description of problem:
I have one USB headset unit. In particular: Plantronics C3220 https://www.amazon.es/Plantronics-Blackwire-C3220-Auriculares-est%C3%A9reo/dp/B07K7XPBSQ

When I plug in the USB, the audio input and output channels are not available in GNOME.

Version-Release number of selected component (if applicable):
pulseaudio-13.99.1-4.fc32.x86_64

How reproducible: See below (I hate this question).

Steps to Reproduce:
1. Open GNOME session.
2. Choose some audio in/out devices.
3. Open some sound app so you can see the effect.
4. Plug in the headset.
5. Go to gnome settings and try to use it. No way, headset in/out channels are missing.
6. Press Alt+F2 and execute `pulseaudio -k`.
7. GNOME session restarts (I use X.org because of nvidia graphics card).
8. Now all in/out sound channels are available.

Actual results: See above.


Expected results: In step 5 you should be able to use the headset right away.


Additional info:
I use F32 Silverblue.

Comment 1 Wim Taymans 2020-09-29 10:08:41 UTC
I believe this is caused by a race between pulseaudio and PipeWire, it should be fixed with this update:


https://bodhi.fedoraproject.org/updates/FEDORA-2020-83145d0062

Comment 2 Fedora Update System 2020-09-29 10:09:43 UTC
FEDORA-2020-83145d0062 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-83145d0062

Comment 3 Fedora Update System 2020-09-30 01:21:42 UTC
FEDORA-2020-83145d0062 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-83145d0062`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-83145d0062

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2020-10-01 01:29:00 UTC
FEDORA-2020-83145d0062 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.