Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1887293 - [abrt] dnf: addErase(): transaction.py:103:addErase:_rpm.error: package not installed
Summary: [abrt] dnf: addErase(): transaction.py:103:addErase:_rpm.error: package not i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 33
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: nsella
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:7b286f8e7a59c251f2dd8a392cd...
: 1970894 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-12 05:09 UTC by phnevsa
Modified: 2021-07-10 20:14 UTC (History)
23 users (show)

Fixed In Version: dnf-4.8.0-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-15 07:21:08 UTC
Type: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (174.61 KB, text/plain)
2020-10-12 05:09 UTC, phnevsa
no flags Details
File: backtrace (1.43 KB, text/plain)
2020-10-12 05:09 UTC, phnevsa
no flags Details
File: cpuinfo (2.24 KB, text/plain)
2020-10-12 05:09 UTC, phnevsa
no flags Details
File: dnf-makecache.log (1.37 KB, text/plain)
2020-10-12 05:09 UTC, phnevsa
no flags Details
File: environ (2.86 KB, text/plain)
2020-10-12 05:09 UTC, phnevsa
no flags Details
File: mountinfo (2.95 KB, text/plain)
2020-10-12 05:09 UTC, phnevsa
no flags Details
File: namespaces (172 bytes, text/plain)
2020-10-12 05:09 UTC, phnevsa
no flags Details
File: open_fds (1.77 KB, text/plain)
2020-10-12 05:09 UTC, phnevsa
no flags Details

Description phnevsa 2020-10-12 05:09:08 UTC
Version-Release number of selected component:
dnf-4.2.23-2.fc33

Additional info:
reporter:       libreport-2.14.0
cgroup:         0::/user.slice/user-1000.slice/user/apps.slice/apps-org.gnome.Terminal.slice/vte-spawn-14c20747-7347-465a-93fb-9c35c9f1af2b.scope
cmdline:        /usr/bin/python3 /usr/bin/dnf upgrade --refresh -y
crash_function: addErase
exception_type: _rpm.error
executable:     /usr/bin/dnf
interpreter:    python3-3.9.0~rc1-2.fc33.x86_64
kernel:         5.8.6-301.fc33.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
transaction.py:103:addErase:_rpm.error: package not installed

Traceback (most recent call last):
  File "/usr/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.9/site-packages/dnf/cli/main.py", line 201, in user_main
    errcode = main(args)
  File "/usr/lib/python3.9/site-packages/dnf/cli/main.py", line 67, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.9/site-packages/dnf/cli/main.py", line 106, in _main
    return cli_run(cli, base)
  File "/usr/lib/python3.9/site-packages/dnf/cli/main.py", line 130, in cli_run
    ret = resolving(cli, base)
  File "/usr/lib/python3.9/site-packages/dnf/cli/main.py", line 176, in resolving
    base.do_transaction(display=displays)
  File "/usr/lib/python3.9/site-packages/dnf/cli/cli.py", line 243, in do_transaction
    tid = super(BaseCli, self).do_transaction(display)
  File "/usr/lib/python3.9/site-packages/dnf/base.py", line 825, in do_transaction
    self.transaction._populate_rpm_ts(self._ts)
  File "/usr/lib/python3.9/site-packages/dnf/db/group.py", line 333, in _populate_rpm_ts
    ts.addErase(tsi.pkg.idx)
  File "/usr/lib64/python3.9/site-packages/rpm/transaction.py", line 103, in addErase
    raise rpm.error("package not installed")
_rpm.error: package not installed

Local variables in innermost frame:
self: <rpm.transaction.TransactionSet object at 0x7f7d44b2a640>
item: 1496
hdrs: []
dbi: 0

Comment 1 phnevsa 2020-10-12 05:09:12 UTC
Created attachment 1720816 [details]
File: _var_log_dnf.log

Comment 2 phnevsa 2020-10-12 05:09:14 UTC
Created attachment 1720817 [details]
File: backtrace

Comment 3 phnevsa 2020-10-12 05:09:15 UTC
Created attachment 1720819 [details]
File: cpuinfo

Comment 4 phnevsa 2020-10-12 05:09:17 UTC
Created attachment 1720820 [details]
File: dnf-makecache.log

Comment 5 phnevsa 2020-10-12 05:09:18 UTC
Created attachment 1720823 [details]
File: environ

Comment 6 phnevsa 2020-10-12 05:09:20 UTC
Created attachment 1720825 [details]
File: mountinfo

Comment 7 phnevsa 2020-10-12 05:09:21 UTC
Created attachment 1720826 [details]
File: namespaces

Comment 8 phnevsa 2020-10-12 05:09:22 UTC
Created attachment 1720828 [details]
File: open_fds

Comment 9 Jaroslav Mracek 2020-10-12 11:46:22 UTC
It looks like that the problem was triggered by a change of rpmdb on the background. We are developing a patch that will provide a better information, but it will result in DNF termination.

Comment 10 Taavi 2020-11-13 11:28:10 UTC
It seems to happen when someone tries to update packages using the KDE tray icon but the actual packages have already been upgraded

Comment 11 overkilled 2020-12-03 01:26:16 UTC
*** Bug 1903866 has been marked as a duplicate of this bug. ***

Comment 12 Dennis Schridde 2020-12-06 10:07:46 UTC
*** Bug 1904773 has been marked as a duplicate of this bug. ***

Comment 13 Haadi 2020-12-20 15:04:30 UTC
*** Bug 1909509 has been marked as a duplicate of this bug. ***

Comment 14 Johannes Kalliauer 2020-12-28 11:06:42 UTC
*** Bug 1911249 has been marked as a duplicate of this bug. ***

Comment 15 yvzbulut 2021-02-14 21:32:55 UTC
*** Bug 1928564 has been marked as a duplicate of this bug. ***

Comment 17 james.p.elford 2021-03-26 08:33:11 UTC
Similar problem has been detected:

This error was present when resuming my laptop

reporter:       libreport-2.14.0
cgroup:         0::/user.slice/user-1000.slice/user/app-gnome-Alacritty-244627.scope
cmdline:        /usr/bin/python3 /usr/bin/dnf update --all --refresh -y
crash_function: addErase
exception_type: _rpm.error
executable:     /usr/bin/dnf
interpreter:    python3-3.9.2-1.fc33.x86_64
kernel:         5.10.19-200.fc33.x86_64
package:        dnf-4.6.0-1.fc33
reason:         transaction.py:103:addErase:_rpm.error: package not installed
runlevel:       N 5
type:           Python3
uid:            0

Comment 18 Rafael Arrifano 2021-04-10 20:57:14 UTC
*** Bug 1948219 has been marked as a duplicate of this bug. ***

Comment 19 lessfoobar 2021-04-23 12:19:10 UTC
*** Bug 1952874 has been marked as a duplicate of this bug. ***

Comment 20 Marek Blaha 2021-06-14 11:34:16 UTC
*** Bug 1970894 has been marked as a duplicate of this bug. ***

Comment 21 Fedora Update System 2021-06-15 07:21:08 UTC
FEDORA-2021-78c5f8c03d has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 22 Eduardo 2021-06-27 10:35:54 UTC
*** Bug 1976570 has been marked as a duplicate of this bug. ***

Comment 23 jessegarciafilm 2021-07-10 20:14:44 UTC
Similar problem has been detected:

Not aware of how it happened.

$ dnf update -y

reporter:       libreport-2.15.2
cgroup:         0::/user.slice/user-1000.slice/user/app.slice/app-org.gnome.Terminal.slice/vte-spawn-f6f9e7ba-d034-40d4-82c5-2a4c63e11102.scope
cmdline:        /usr/bin/python3 /usr/bin/dnf update
crash_function: addErase
exception_type: _rpm.error
executable:     /usr/bin/dnf
interpreter:    python3-3.9.2-1.fc34.x86_64
kernel:         5.11.12-300.fc34.x86_64
package:        dnf-4.6.1-1.fc34
reason:         transaction.py:103:addErase:_rpm.error: package not installed
runlevel:       N 5
type:           Python3
uid:            0


Note You need to log in before you can comment on or make changes to this bug.