Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1888197 - fedora-release and fedora-repos 33-1 is not available
Summary: fedora-release and fedora-repos 33-1 is not available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-release
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mohan Boddu
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 1888202 (view as bug list)
Depends On:
Blocks: F33FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2020-10-14 11:25 UTC by Kamil Páral
Modified: 2020-10-14 17:11 UTC (History)
13 users (show)

Fixed In Version: fedora-release-33-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-14 17:11:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Kamil Páral 2020-10-14 11:25:04 UTC
In current F33 repos (and F33 RC 1.1 compose), there is fedora-release-common-33-0.15.noarch, which means it doesn't have 1.0 version. Our OpenQA test claims that's invalid:

> # Test died: RC candidate or update compose should not have 0.x versioned fedora-release! at /var/lib/openqa/share/tests/fedora/tests/os_release.pm line 108.
https://openqa.fedoraproject.org/tests/694483#step/os_release/6

I'm not sure whether this is a hard blocker or not (from the releng PoV), but proposing as one.

Comment 1 Kamil Páral 2020-10-14 11:49:55 UTC
This might actually cause bug 1888202

Comment 2 Ben Cotton 2020-10-14 12:35:47 UTC
Does it make sense to close this as a duplicate of 1888202 for easier tracking, etc?

Comment 3 Kamil Páral 2020-10-14 13:24:13 UTC
I'm inquiring at #anaconda whether this really is the root cause for bug 1888202

Comment 4 Peter Robinson 2020-10-14 13:33:20 UTC
(In reply to Kamil Páral from comment #3)
> I'm inquiring at #anaconda whether this really is the root cause for bug
> 1888202

Yes, anaconda has a check for that, we also need a 33-1 build to turn off updates-testing and not install the -rawhide repos by default as per standard release criteria

Comment 5 Fedora Update System 2020-10-14 13:36:09 UTC
FEDORA-2020-941b0d5a2e has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-941b0d5a2e

Comment 6 Kamil Páral 2020-10-14 13:38:26 UTC
RELEASE=$(rpm -q --qf '%{Release}' --whatprovides system-release)
if [ "${RELEASE:0:2}" = "0." ]; then
    export ANACONDA_ISFINAL="false"
else
    export ANACONDA_ISFINAL="true"
fi

https://github.com/rhinstaller/anaconda/blob/master/data/liveinst/liveinst#L66

Comment 7 Kamil Páral 2020-10-14 13:49:26 UTC
(In reply to Fedora Update System from comment #5)
> FEDORA-2020-941b0d5a2e has been submitted as an update to Fedora 33.
> https://bodhi.fedoraproject.org/updates/FEDORA-2020-941b0d5a2e

Tested.

Comment 8 Fedora Update System 2020-10-14 14:21:40 UTC
FEDORA-2020-941b0d5a2e has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-941b0d5a2e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-941b0d5a2e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Adam Williamson 2020-10-14 15:56:36 UTC
*** Bug 1888202 has been marked as a duplicate of this bug. ***

Comment 10 Adam Williamson 2020-10-14 16:28:35 UTC
Criteria here are:

"No notices or alerts about pre-release status may be shown as part of installation or critical path actions on release-blocking desktops" (without final fedora-release, we get pre-release messages on lives)

"A fedora-release package containing the correct names, information and repository configuration for a final Fedora release must be present on release-blocking images and the appropriately versioned generic-release package must be available in the release repository" (without final fedora-repos, we have updates-testing enabled by default)

We need to update that second criterion to reference fedora-repos, I think.

Comment 11 Geoffrey Marr 2020-10-14 16:35:54 UTC
The decision to classify this bug as an "AcceptedBlocker (Final)" was made. [0]

[0] https://pagure.io/fedora-qa/blocker-review/issue/169

Comment 12 Geoffrey Marr 2020-10-14 16:36:56 UTC
The decision to classify this bug as an "AcceptedBlocker (Final)" was made. [0]

[0] https://pagure.io/fedora-qa/blocker-review/issue/169

Comment 13 Adam Williamson 2020-10-14 16:37:30 UTC
so close...

why would we use the same text for bugzilla and the voting app, that would be way too easy

Comment 14 Fedora Update System 2020-10-14 17:11:16 UTC
FEDORA-2020-941b0d5a2e has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.