Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1888954 - Can't upgrade to Fedora 33 if package libreoffice-kde5 is installed
Summary: Can't upgrade to Fedora 33 if package libreoffice-kde5 is installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Tardon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1893114 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-16 14:45 UTC by Yaroslav Sidlovsky
Modified: 2020-10-31 00:19 UTC (History)
5 users (show)

Fixed In Version: libreoffice-7.0.2.2-3.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-31 00:19:12 UTC
Type: Bug


Attachments (Terms of Use)

Description Yaroslav Sidlovsky 2020-10-16 14:45:04 UTC
Description of problem:
I've got installed package `libreoffice-kde5` in my system and because of that I see error when running `sudo dnf system-upgrade download --releasever=33`.

Version-Release number of selected component (if applicable):
libreoffice-kde5-6.4.7.2-1.fc32.x86_64

How reproducible:
Always.


Steps to Reproduce:
1. sudo dnf install libreoffice-kde5
2. sudo dnf system-upgrade download --releasever=33

Actual results:
...
Error: 
 Problem: package libreoffice-kde5-1:6.4.7.2-1.fc32.x86_64 requires libreoffice-core(x86-64) = 1:6.4.7.2-1.fc32, but none of the providers can be installed
  - libreoffice-core-1:6.4.7.2-1.fc32.x86_64 does not belong to a distupgrade repository
  - problem with installed package libreoffice-kde5-1:6.4.7.2-1.fc32.x86_64
(try to add '--skip-broken' to skip uninstallable packages)


Expected results:
Command "system-upgrade download" ends without errors.

Also I can install both packages `libreoffice-kde5` and `libreoffice-kf5` at the same time.
I think that `libreoffice-kde5` must be replaced with `libreoffice-kf5` automatically.

Comment 1 David Tardon 2020-10-24 16:54:49 UTC
Yeah, Obsoletes entry for libreoffice-kde5 is broken, because the version used there is actually lower than the current version of libreoffice in F-32...

Comment 2 Fedora Update System 2020-10-25 06:20:54 UTC
FEDORA-2020-1b35642b96 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-1b35642b96

Comment 3 Fedora Update System 2020-10-26 01:18:02 UTC
FEDORA-2020-1b35642b96 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-1b35642b96`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-1b35642b96

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2020-10-27 02:37:42 UTC
FEDORA-2020-40d119ea58 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-40d119ea58`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-40d119ea58

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Caolan McNamara 2020-10-30 09:31:08 UTC
*** Bug 1893114 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2020-10-31 00:19:12 UTC
FEDORA-2020-40d119ea58 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.