Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1891149 - Typo in PDALConfig.cmake
Summary: Typo in PDALConfig.cmake
Alias: None
Product: Fedora
Classification: Fedora
Component: PDAL
Version: 33
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: markusN
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2020-10-23 22:40 UTC by Nyall Dawson
Modified: 2020-11-13 03:46 UTC (History)
2 users (show)

Fixed In Version: PDAL-2.2.0-2.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2020-11-13 03:46:53 UTC
Type: Bug

Attachments (Terms of Use)

Description Nyall Dawson 2020-10-23 22:40:24 UTC
Description of problem:

There is a typo on line 47 of PDALConfig.cmake:

instead of
    foreach(_dir /usr/usr/lib64)

this should be

    foreach(_dir /usr /usr/lib64)

(ie. missing space before /usr/lib64)

Version-Release number of selected component (if applicable):

Comment 1 markusN 2020-10-24 09:18:04 UTC
In my local copy I don't find that, nor any trace here:

Do you see anything wrong in the SPEC file?

Comment 2 Nyall Dawson 2020-10-26 05:09:03 UTC
Looks like it was changed upstream by this commit

I see this on multiple workstations -- I just tried installing PDAL-devel on a new one and see the same issue.

Comment 3 markusN 2020-10-27 15:24:27 UTC
Which PDAL-devel version did you install?

I am currently trying to package PDAL 2.2.0 but it fails (see #1891154)

Comment 4 Nyall Dawson 2020-10-27 22:24:22 UTC
It's PDAL-2.1.0-6.fc32.src.rpm

Comment 5 markusN 2020-10-28 08:18:10 UTC
- PDAL 2.1.0 released on Mar 20, 2020
- the upstream commit is from Apr 28, 2020
- PDAL 2.2.0 released on Aug 28, 2020

Hence, I suppose that with the PDAL 2.2.0 this bug will be solved.

Comment 6 Fedora Update System 2020-11-04 17:55:20 UTC
FEDORA-2020-3750b71c79 has been submitted as an update to Fedora 33.

Comment 7 Fedora Update System 2020-11-05 03:28:19 UTC
FEDORA-2020-3750b71c79 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-3750b71c79`
You can provide feedback for this update here:

See also for more information on how to test updates.

Comment 8 Fedora Update System 2020-11-13 03:46:53 UTC
FEDORA-2020-3750b71c79 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.