Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1896097 - resizing using left side of window causes window to disappear off left edge of screen
Summary: resizing using left side of window causes window to disappear off left edge o...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-11-09 17:55 UTC by Charles R. Anderson
Modified: 2020-11-19 01:29 UTC (History)
16 users (show)

Fixed In Version: mutter-3.38.1-2.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-19 01:29:26 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Video showing the failure to resize firefox using left window edge (deleted)
2020-11-09 17:55 UTC, Charles R. Anderson
no flags Details

Description Charles R. Anderson 2020-11-09 17:55:28 UTC
Created attachment 1727895 [details]
Video showing the failure to resize firefox using left window edge

Description of problem:
Attempting to resize the firefox window in Wayland using the left edge of the firefox window causes the entire firefox window to immediately shoot off the left edge of the screen and disappear, making it very difficult to get back.  You can get the window back by going into overview mode using the upper left hot corner, and dragging the missing window onto a new desktop, which causes a tiny part of the window to show up on the left edge of the screen, which you can grab and then resize/move.

Version-Release number of selected component (if applicable):
firefox-82.0.2-5.fc32.x86_64

How reproducible:
always

Steps to Reproduce:
1. Use mouse to grab firefox left window border and move it to the right.

Actual results:
Firefox window shoots off the left edge of the desktop.

Expected results:
Resize firefox window smaller.

Additional info:
See video attachment for the behavior.

Comment 1 Charles R. Anderson 2020-11-09 18:03:36 UTC
Moving component to mutter, since this bug happens on other windows too, not just firefox.

Comment 2 Charles R. Anderson 2020-11-09 18:07:10 UTC
Package versions:

mutter-3.36.7-1.fc32.x86_64
gnome-shell-3.36.7-1.fc32.x86_64

Comment 3 Fedora Update System 2020-11-17 14:04:22 UTC
FEDORA-2020-543204d787 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-543204d787

Comment 4 Fedora Update System 2020-11-18 01:08:44 UTC
FEDORA-2020-543204d787 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-543204d787`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-543204d787

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2020-11-19 01:29:26 UTC
FEDORA-2020-543204d787 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.