Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1898495 - Cannot activate bluetooth after kernel 5.9 update
Summary: Cannot activate bluetooth after kernel 5.9 update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-11-17 10:31 UTC by michele.riva
Modified: 2021-03-18 07:49 UTC (History)
24 users (show)

Fixed In Version: kernel-5.10.6-200.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-14 01:39:29 UTC
Type: Bug


Attachments (Terms of Use)
Dmesg since boot (103.86 KB, text/plain)
2020-11-17 10:31 UTC, michele.riva
no flags Details
Screenshot of issue in Gnome control panel (42.02 KB, image/png)
2020-11-20 19:07 UTC, michele.riva
no flags Details

Description michele.riva 2020-11-17 10:31:08 UTC
Created attachment 1730086 [details]
Dmesg since boot

1. Please describe the problem:
After upgrading a fresh install of Fedora 33 (kernel 5.8.15-301) to kernel 5.9.8-200, triggering the bluetooth on/off switch in both the control center and the applet does not have any effect.


5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:
Did not test yet

6. Are you running any modules that not shipped with directly Fedora's kernel?:
No

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.
See attached dmesg.txt

Comment 1 fhortner 2020-11-17 10:53:01 UTC
seems to be a kernel issue, since also other distros are affected.
Seems to be an issue with the kernel trying to use Link-Layer Privacy for BLE devices

see bugzilla.kernel.org:
Bluetooth mouse Logitech M720 doesn't work: https://bugzilla.kernel.org/show_bug.cgi?id=209717
Bluetooth connection to Logitech MX Master 2S lost after each reboot: https://bugzilla.kernel.org/show_bug.cgi?id=209745

kenel patch already available:
Bluetooth: Fix: LL PRivacy BLE device fails to connect: https://patchwork.kernel.org/project/bluetooth/patch/20201022082304.31757-1-sathish.narasimman@intel.com/

also known at ArchWiki:
https://wiki.archlinux.org/index.php/Bluetooth#Problems_with_all_BLE_devices_on_kernel_5.9+

Comment 2 Justin M. Forbes 2020-11-17 12:31:50 UTC

*** This bug has been marked as a duplicate of bug 1897038 ***

Comment 3 michele.riva 2020-11-17 14:08:05 UTC
Actually, I can't even reach the pairing step thus it might be something related, yet different. Gnome's control panel simply shows that bluetooth is turned off, event though the switch on the top right corner is on, thus no device is listed (and probably not even scanned).

Comment 4 michele.riva 2020-11-20 19:05:47 UTC
I confirm this bug is NOT solved by kernel 5.9.9-200.fc33 from https://bodhi.fedoraproject.org/updates/FEDORA-2020-febe24a7ca
This is a different issue than bluetooth pairing.

Comment 5 michele.riva 2020-11-20 19:07:06 UTC
Created attachment 1731420 [details]
Screenshot of issue in Gnome control panel

Comment 6 Michael Carney 2020-11-20 21:06:08 UTC
I can also confirm that kernel 5.9.9-200.fc33 *DOES NOT* fix this problem -- it still remains (bluetooth is completely disabled). This bug is NOT a duplicate of 1897038 - it has nothing to do with pairing. Please reopen this bug.

Returning to 5.8.18-300.fc33 restores bluetooth functionality.

Comment 7 Michael Carney 2020-11-20 21:13:45 UTC
I'm using the KDE spin.

Comment 8 Michael Carney 2020-11-28 01:41:38 UTC
This problem has been fixed upstream:

 FS#68749 - [linux] Bluetooth not working with rtl8822ce kernel 5.9.x 

https://bugs.archlinux.org/task/68749

Comment 9 Michael Carney 2020-12-03 17:39:09 UTC
michele, can you reopen this bug as submitter? I want to make sure that any realtek bluetooth adapter users see this. Thanks.

Comment 10 Michael Carney 2020-12-14 18:53:44 UTC
Patch:
https://marc.info/?l=linux-bluetooth&m=160378222632366&w=2

Comment 11 Michael Carney 2020-12-20 19:28:12 UTC
bugzilla.kernel.org: Bug 210453 - [BISECTED] rtl8822cu device : "Bluetooth : No device found"

Comment 12 Michael Carney 2020-12-20 19:41:05 UTC
Fix confirmed in kernel.org linux-next.

Comment 13 Justin M. Forbes 2021-01-07 13:46:49 UTC
I have added this patch to the stabilization tree. It will be in kernels beginning with 5.10.6.

Comment 14 Fedora Update System 2021-01-12 00:50:42 UTC
FEDORA-2021-3465ada1ca has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-3465ada1ca

Comment 15 Fedora Update System 2021-01-13 01:28:07 UTC
FEDORA-2021-3465ada1ca has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-3465ada1ca`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-3465ada1ca

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2021-01-14 01:39:29 UTC
FEDORA-2021-3465ada1ca has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 17 Rui Miguel Seabra 2021-01-17 19:12:30 UTC
I don't think this caught all the recent bluetooth issues...

# uname -srvmpio
Linux 5.10.7-200.fc33.x86_64 #1 SMP Tue Jan 12 20:20:11 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

I need to reboot in order to be able to reconnect to my bluetooth headset.

Comment 18 Rui Miguel Seabra 2021-01-17 19:17:04 UTC
Sorry, reconnect is not the correct term, it connects, it's just that the sound profile never gets set to a2dp.

pactl info
Server String: /run/user/xxx/pulse/native
Library Protocol Version: 34
Server Protocol Version: 34
Is Local: yes
Client Index: 8
Tile Size: 65472
User Name: xxx
Host Name: xxxx
Server Name: pulseaudio
Server Version: 14.0-rebootstrapped
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: bluez_sink.E8_07_BF_33_5A_30.a2dp_sink
Default Source: alsa_input.pci-0000_00_1f.3.analog-stereo
Cookie: fd4b:0ee8

But the sound still comes from the laptop's speakers.

Comment 19 Rui Miguel Seabra 2021-01-17 19:23:22 UTC
After reboot, first connection

$ pactl info
Server String: /run/user/xx/pulse/native
Library Protocol Version: 34
Server Protocol Version: 34
Is Local: yes
Client Index: 8
Tile Size: 65472
User Name: xx
Host Name: xx
Server Name: pulseaudio
Server Version: 14.0-rebootstrapped
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1f.3.analog-stereo
Default Source: alsa_input.pci-0000_00_1f.3.analog-stereo
Cookie: 525f:85d3

Unsure of how to specify by command, I go to the Gnome Shell's sound settings, verify that it says "speakers" and specify the proper headset output device...

$ pactl info
Server String: /run/user/xx/pulse/native
Library Protocol Version: 34
Server Protocol Version: 34
Is Local: yes
Client Index: 11
Tile Size: 65472
User Name: xx
Host Name: xx
Server Name: pulseaudio
Server Version: 14.0-rebootstrapped
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: bluez_sink.E8_07_BF_33_5A_30.a2dp_sink
Default Source: alsa_input.pci-0000_00_1f.3.analog-stereo
Cookie: 525f:85d3

BUT the sound still comes from speakers.

I'm going two kernels backward to kernel-core-5.9.13-200.fc33.x86_64 in order to check if it works better.

Comment 20 Rui Miguel Seabra 2021-01-17 19:26:24 UTC
Nopes, same behaviour.

Comment 21 Rui Miguel Seabra 2021-01-17 19:29:35 UTC
Ah... it seems that the gnome shell settings application is sending the test to the speakers, but sound is indeed coming from the headset! confusing for users, though. very confusing.

Comment 22 trubonru 2021-03-18 07:49:30 UTC
I can confirm this bug. Device succsessfully connect to my wireless headset (Headset play a sound that signalaize that device is connected). But sound still goes from laptop speakers. there is also no sound profile for headset in my gnome sound settings

Fedora 34 on my HP laptop
Kernel version: 5.11.6-300.fc34.x86_64


Note You need to log in before you can comment on or make changes to this bug.