Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1905701 - Backport "Fortran dynamic type related fixes"
Summary: Backport "Fortran dynamic type related fixes"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: gdb
Version: 8.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 8.0
Assignee: Keith Seitz
QA Contact: Michal Kolar
URL:
Whiteboard:
Depends On: 1905687
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-12-08 21:17 UTC by Keith Seitz
Modified: 2021-09-17 14:55 UTC (History)
8 users (show)

Fixed In Version: gdb-8.2-15.el8
Doc Type: No Doc Update
Doc Text:
Clone Of: 1905687
Environment:
Last Closed: 2021-05-18 15:46:02 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)

Description Keith Seitz 2020-12-08 21:17:03 UTC
+++ This bug was initially created as a clone of Bug #1905687 +++

Originally reported/triaged by Andrew Dinn:

I have run up against a problem with the versions of gdb that are out in the field that relates to the use of data_location properties on DWARF class/struct info records. I need to use this DWARF feature in order to fully implement Java debuginfo for GraalVM native Java apps. The data_location attribute is needed to ensure that Java oops (typed as DWARF pointer types which reference the underlying class/struct data) are adjusted from a Java-specific encoding of the address to a direct memory pointer before gdb dereferences the oop to locate the underlying data.

 - In one mode of image generation oops are addresses modulo extra tag info in the bottom 3 bits so a locexpr describes how to mask off the relevant bits.

 - In another mode of image generation oops are offsets from a heap base held in a register so a locexpr describes how to fetch the relevant register value and add it to the oop (offset).

The data_location attribute on the target object provides the necessary locexpr.

My problem is not to do with the conversion itself. That all works fine. It goes wrong when I ask gdb to print the relevant object data (see example after sig). The value that gets inserted into the history has an unresolved dynamic type and this trips an assert .

This problem should be caught and dealt with before the value is passed to the print code and indeed it has been fixed in gdb 10.1. The patch is detailed in the asssociated ChangeLog as follows:

2020-07-25  Andrew Burgess  <andrew.burgess>

    PR fortran/23051
    PR fortran/26139
    * valops.c (value_ind): Pass address to
    readjust_indirect_value_type.
    * value.c (readjust_indirect_value_type): Make parameter
    non-const, and add extra address parameter.  Resolve original type
    before using it.
    * value.h (readjust_indirect_value_type): Update function
    signature and comment.

--- Additional comment from Keith Seitz on 2020-12-08 20:30:10 UTC ---



--- Additional comment from Keith Seitz on 2020-12-08 20:31:00 UTC ---

Testing patch.

Comment 3 Michal Kolar 2021-01-05 08:13:13 UTC
Tested against gdb-8.2-15.el8.

Comment 6 Michal Kolar 2021-01-05 12:26:44 UTC
Reproduced against gdb-8.2-12.el8 and verified against gdb-8.2-15.el8

Comment 9 errata-xmlrpc 2021-05-18 15:46:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (gdb bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1836


Note You need to log in before you can comment on or make changes to this bug.