Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1906811 - python-absl-py fails to build with Python 3.10: detects Python 3.1 instead of Python 3.10
Summary: python-absl-py fails to build with Python 3.10: detects Python 3.1 i...
Alias: None
Product: Fedora
Classification: Fedora
Component: python-absl-py
Version: rawhide
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Ben Beasley
QA Contact: Fedora Extras Quality Assurance
Depends On:
Blocks: PYTHON3.10
TreeView+ depends on / blocked
Reported: 2020-12-11 13:29 UTC by Tomáš Hrnčiar
Modified: 2020-12-11 15:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2020-12-11 15:48:01 UTC
Type: Bug

Attachments (Terms of Use)

Description Tomáš Hrnčiar 2020-12-11 13:29:22 UTC
python-absl-py fails to build with Python 3.10.0a3.

This seems like a problem with detecting the correct version of Python (3.10 instead of 3.1). 

You can use (something like) this instead: 
$ python3.10 -c "import sys; sys.stdout.write('{}.{}'.format(*sys.version_info[:2]))" 

py_version = platform.python_version_tuple()
if py_version < ('2', '7') or py_version[0] == '3' and py_version < ('3', '4'):
   raise RuntimeError('Python version 2.7 or 3.4+ is required.')

For the build logs, see:

For all our attempts to build python-absl-py with Python 3.10, see:

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Ben Beasley 2020-12-11 15:48:01 UTC
Thanks, this is useful. I have fixed this in Rawhide with a trivial patch in 0.11.0-4, and submitted an upstream report at

It’s mildly surprising that string-based version detection made it through code review at A Large Internet Company in the first place, especially in their foundational Python library.

Note You need to log in before you can comment on or make changes to this bug.