Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1909621 - gnome-shell stopped work after upgrade glib2 to 2.67.1-1.fc34
Summary: gnome-shell stopped work after upgrade glib2 to 2.67.1-1.fc34
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glib2
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F34BetaBlocker F34BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-12-21 08:15 UTC by Mikhail
Modified: 2020-12-21 19:14 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-21 19:14:03 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
photo with broken gnome-shell (deleted)
2020-12-21 08:15 UTC, Mikhail
no flags Details
system log (deleted)
2020-12-21 08:17 UTC, Mikhail
no flags Details
system logs (deleted)
2020-12-21 08:21 UTC, Mikhail
no flags Details
gnome-shell backtrace (machine 1) (deleted)
2020-12-21 16:08 UTC, Mikhail
no flags Details
gnome-shell backtrace (machine 2) (deleted)
2020-12-21 17:42 UTC, Mikhail
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME glib issues 2273 0 None None None 2020-12-21 19:14:27 UTC

Description Mikhail 2020-12-21 08:15:47 UTC
Created attachment 1740906 [details]
photo with broken gnome-shell

Description of problem:
gnome-shell stopped work after upgrade glib2 to 2.67.1-1.fc34

Version-Release number of selected component (if applicable):
Last good version is 2.67.0-7.fc34

How reproducible:
1) Upgrade glib2 to 2.67.1-1.fc34
2) Reboot computer

Comment 1 Mikhail 2020-12-21 08:17:58 UTC
Created attachment 1740907 [details]
system log

Comment 2 Mikhail 2020-12-21 08:21:21 UTC
Created attachment 1740908 [details]
system logs

Comment 3 Mikhail 2020-12-21 16:08:56 UTC
Created attachment 1741041 [details]
gnome-shell backtrace (machine 1)

Comment 4 Mikhail 2020-12-21 17:42:36 UTC
Created attachment 1741048 [details]
gnome-shell backtrace (machine 2)

Comment 5 Fedora Blocker Bugs Application 2020-12-21 19:04:19 UTC
Proposed as a Blocker and Freeze Exception for 34-beta by Fedora user mikhail using the blocker tracking app because:

 Because gnome-shell will not run on computers after upgrade to Fedora 34.

Comment 6 Adam Williamson 2020-12-21 19:14:03 UTC
This was already reported and fixed in -2. See Kevin's mail yesterday, "rawhide headsup: glib2-2.67.1 causes gdm crash".


Note You need to log in before you can comment on or make changes to this bug.