Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1923601 - dom4j: FTBFS in Fedora rawhide/f34
Summary: dom4j: FTBFS in Fedora rawhide/f34
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dom4j
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F34FTBFS
TreeView+ depends on / blocked
 
Reported: 2021-02-01 17:18 UTC by Fedora Release Engineering
Modified: 2021-05-12 16:12 UTC (History)
6 users (show)

Fixed In Version: dom4j-2.0.3-1.fc34 dom4j-2.0.3-1.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-29 21:28:47 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2021-02-01 17:18 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2021-02-01 17:18 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2021-02-01 17:18 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2021-02-01 17:18:51 UTC
dom4j failed to build from source in Fedora rawhide/f34

https://koji.fedoraproject.org/koji/taskinfo?taskID=60912983


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
Please fix dom4j at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
dom4j will be orphaned. Before branching of Fedora 35,
dom4j will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 1 Fedora Release Engineering 2021-02-01 17:18:54 UTC
Created attachment 1753758 [details]
build.log

Comment 2 Fedora Release Engineering 2021-02-01 17:18:55 UTC
Created attachment 1753759 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2021-02-01 17:18:56 UTC
Created attachment 1753760 [details]
state.log

Comment 4 Ben Cotton 2021-02-09 15:57:35 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 5 Fedora Release Engineering 2021-02-14 04:27:11 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 34.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-03-29).

A week before the mass branching of Fedora 35 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 33 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-35/f-35-key-tasks.html

Comment 6 Hans de Goede 2021-02-22 16:41:20 UTC
I've been looking into fixing the dom4j FTBFS I've made some progress but now I'm stuck because part of the problem is with msv.

I've managed to reduce the number of build errors in dom4j by dealing with the rename / moving of the org.relaxng.datatype class to com.sun.tools.rngdatatype. For me this required 2 changes:

1. Add a patch fixing all the imports, e.g. :

--- dom4j-2.0.0/src/main/java/org/dom4j/datatype/SchemaParser.java~     2016-04-13 22:15:15.00
+++ dom4j-2.0.0/src/main/java/org/dom4j/datatype/SchemaParser.java      2021-02-22 16:56:08.44
@@ -24,8 +24,8 @@ import org.dom4j.QName;
 import org.dom4j.io.SAXReader;
 import org.dom4j.util.AttributeHelper;

-import org.relaxng.datatype.DatatypeException;
-import org.relaxng.datatype.ValidationContext;
+import com.sun.tools.rngdatatype.DatatypeException;
+import com.sun.tools.rngdatatype.ValidationContext;

 import org.xml.sax.EntityResolver;
 import org.xml.sax.InputSource;

etc.


2. Add a BR + pom dep on the replacement jaxb-relaxng-datatype pkg:

BuildRequires: jaxb-relaxng-datatype

%pom_add_dep com.sun.xml.bind.external:relaxng-datatype::provided


I wanted to see if I could help with fixing msv, but I'm hitting the following issue there:

sudo dnf builddep msv.spec

No matching package to install: 'mvn(net.java:jvnet-parent:pom:)'

Comment 7 Hans de Goede 2021-04-29 21:28:47 UTC
The FTBFS has been fixed and this package has been rebuild for rawhide now, closing.

Comment 8 Fedora Update System 2021-05-03 12:43:56 UTC
FEDORA-2021-8015a8cdc4 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-8015a8cdc4

Comment 9 Fedora Update System 2021-05-03 12:44:04 UTC
FEDORA-2021-f28c870528 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-f28c870528

Comment 10 Fedora Update System 2021-05-04 00:32:34 UTC
FEDORA-2021-8015a8cdc4 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-8015a8cdc4`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-8015a8cdc4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2021-05-04 01:09:05 UTC
FEDORA-2021-f28c870528 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-f28c870528`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-f28c870528

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2021-05-12 05:42:05 UTC
FEDORA-2021-f28c870528 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 Fedora Update System 2021-05-12 13:43:48 UTC
FEDORA-2021-8015a8cdc4 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Fedora Update System 2021-05-12 16:12:26 UTC
FEDORA-2021-8015a8cdc4 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.