Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1924008 - Update to sddm-0.19.0-5.fc33 breaks 'su'
Summary: Update to sddm-0.19.0-5.fc33 breaks 'su'
Keywords:
Status: CLOSED DUPLICATE of bug 1922772
Alias: None
Product: Fedora
Classification: Fedora
Component: sddm
Version: 33
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Bříza
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-02 12:19 UTC by Kevin Wolf
Modified: 2021-02-03 16:03 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-03 16:03:38 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Kevin Wolf 2021-02-02 12:19:46 UTC
Description of problem:

After the sddm package was updated, I had problems with switching to another user in a shell running in Konsole with 'su'. After entering the password, it took a long time until anything happened, and when I finally got the shell, I couldn't start any graphical programs: The DISPLAY variable wasn't set, and if I set it manually, the programs couldn't connect anyway.

Downgrading back to sddm-0.18.1-8.fc33.x86_64 resolved the problem.

Version-Release number of selected component (if applicable):
sddm-0.19.0-5.fc33.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Upgrade to sddm-0.19.0-5.fc33 and start a KDE session
2. In a Konsole window, run 'su - otheruser'
3. Try to run a graphical program, e.g. run 'firefox'

Actual results:
After step 2, there is a long delay. In step 3, Firefox fails to start.

Expected results:
No delay in step 2 and the program can successfully start in step 3 like with previous sddm versions.

Comment 1 Rex Dieter 2021-02-03 16:03:38 UTC

*** This bug has been marked as a duplicate of bug 1922772 ***


Note You need to log in before you can comment on or make changes to this bug.