Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1930978 - [abrt] xorg-x11-server-Xorg: System(): Xorg killed by SIGABRT
Summary: [abrt] xorg-x11-server-Xorg: System(): Xorg killed by SIGABRT
Keywords:
Status: CLOSED DUPLICATE of bug 1930977
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 34
Hardware: aarch64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:4eab8afe0507f63de142c1545ab...
Depends On:
Blocks: ARMTracker F34BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2021-02-19 23:24 UTC by Paul Whalen
Modified: 2021-03-03 14:10 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-03 14:10:17 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: backtrace (110.14 KB, text/plain)
2021-02-19 23:24 UTC, Paul Whalen
no flags Details
File: core_backtrace (19.17 KB, text/plain)
2021-02-19 23:24 UTC, Paul Whalen
no flags Details
File: cpuinfo (1.18 KB, text/plain)
2021-02-19 23:24 UTC, Paul Whalen
no flags Details
File: dso_list (8.08 KB, text/plain)
2021-02-19 23:24 UTC, Paul Whalen
no flags Details
File: environ (699 bytes, text/plain)
2021-02-19 23:24 UTC, Paul Whalen
no flags Details
File: limits (1.29 KB, text/plain)
2021-02-19 23:24 UTC, Paul Whalen
no flags Details
File: maps (40.07 KB, text/plain)
2021-02-19 23:24 UTC, Paul Whalen
no flags Details
File: mountinfo (2.74 KB, text/plain)
2021-02-19 23:24 UTC, Paul Whalen
no flags Details
File: open_fds (3.68 KB, text/plain)
2021-02-19 23:24 UTC, Paul Whalen
no flags Details
File: proc_pid_status (1.21 KB, text/plain)
2021-02-19 23:24 UTC, Paul Whalen
no flags Details
File: var_log_messages (10.27 KB, text/plain)
2021-02-19 23:24 UTC, Paul Whalen
no flags Details

Description Paul Whalen 2021-02-19 23:24:20 UTC
Description of problem:
Attempting to boot F34 Workstation on an Nvidia Jetson Nano.

Version-Release number of selected component:
xorg-x11-server-Xorg-1.20.10-5.fc34

Additional info:
reporter:       libreport-2.14.0
backtrace_rating: 4
cgroup:         0::/user.slice/user-984.slice/session-c2.scope
cmdline:        /usr/libexec/Xorg vt1 -displayfd 3 -auth /run/user/984/gdm/Xauthority -nolisten tcp -background none -noreset -keeptty -novtswitch -verbose 3
crash_function: System
executable:     /usr/libexec/Xorg
journald_cursor: s=d55a9ac4f3e740739bf362a2b77352f1;i=cc6;b=ded02adf973940a6b627881eed971702;m=76d777f;t=5bbb6e4775c05;x=118597dac12a087a
kernel:         5.11.0-156.fc34.aarch64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            984

Comment 1 Paul Whalen 2021-02-19 23:24:24 UTC
Created attachment 1758297 [details]
File: backtrace

Comment 2 Paul Whalen 2021-02-19 23:24:25 UTC
Created attachment 1758298 [details]
File: core_backtrace

Comment 3 Paul Whalen 2021-02-19 23:24:26 UTC
Created attachment 1758299 [details]
File: cpuinfo

Comment 4 Paul Whalen 2021-02-19 23:24:27 UTC
Created attachment 1758300 [details]
File: dso_list

Comment 5 Paul Whalen 2021-02-19 23:24:28 UTC
Created attachment 1758301 [details]
File: environ

Comment 6 Paul Whalen 2021-02-19 23:24:29 UTC
Created attachment 1758302 [details]
File: limits

Comment 7 Paul Whalen 2021-02-19 23:24:30 UTC
Created attachment 1758303 [details]
File: maps

Comment 8 Paul Whalen 2021-02-19 23:24:32 UTC
Created attachment 1758304 [details]
File: mountinfo

Comment 9 Paul Whalen 2021-02-19 23:24:33 UTC
Created attachment 1758305 [details]
File: open_fds

Comment 10 Paul Whalen 2021-02-19 23:24:35 UTC
Created attachment 1758306 [details]
File: proc_pid_status

Comment 11 Paul Whalen 2021-02-19 23:24:36 UTC
Created attachment 1758307 [details]
File: var_log_messages

Comment 12 Paul Whalen 2021-02-22 16:45:18 UTC
Proposing as a beta blocker for F34, this affects a supported hardware platform (Jetson Nano).

Comment 13 Olivier Fourdan 2021-02-22 16:50:18 UTC
According to attachment 1758297 [details] the crash occurs in the driver code (nouveau)

Comment 14 Olivier Fourdan 2021-02-22 16:55:18 UTC
You may want to attach the Xorg logs as well, it's always helpful.

Comment 15 Geoffrey Marr 2021-02-22 20:07:57 UTC
Discussed during the 2021-02-22 blocker review meeting: [0]

The decision to delay the classification of this as a blocker bug was made as we suspect this may be a dupe of #1930977. We will punt while pwhalen works that out.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2021-02-22/f34-blocker-review.2021-02-22-17.07.txt

Comment 16 Geoffrey Marr 2021-03-01 21:18:39 UTC
Discussed during the 2021-03-01 blocker review meeting: [0]

The decision to delay the classification of this as a blocker bug was made as we're still waiting for pwhalen to confirm whether this is a dupe of 1930977.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2021-03-01/f34-blocker-review.2021-03-01-17.01.txt

Comment 17 Paul Whalen 2021-03-03 14:10:17 UTC
Closing as a dupe of BZ#1930977.

*** This bug has been marked as a duplicate of bug 1930977 ***


Note You need to log in before you can comment on or make changes to this bug.