Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1931099 - Build version numbers don't match the actual build patchlevel
Summary: Build version numbers don't match the actual build patchlevel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: vim
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Karsten
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-20 16:28 UTC by Peter Heatwole
Modified: 2021-03-08 20:14 UTC (History)
3 users (show)

Fixed In Version: vim-8.2.2541-1.fc33 vim-8.2.2541-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-26 01:09:29 UTC
Type: Bug


Attachments (Terms of Use)

Description Peter Heatwole 2021-02-20 16:28:19 UTC
Description of problem: vim builds since 8.2.2146 don't appear to be tracking the actual vim patchlevel

Version-Release number of selected component (if applicable): all builds since vim-8.2.2146-2.fc33 

How reproducible: always

Steps to Reproduce:
1. Install one of vim-8.2.2451, vim-8.2.2465, vim-8.2.2488, or vim-8.2.2529
2. Run `vim --version | grep 'Included patches'`

Actual results:
Included patches: 1-2311

Expected results:
Included patches: 1-2529

Comment 1 Zdenek Dohnal 2021-02-22 05:18:07 UTC
Hi Peter,

thank you for reporting the issue!

I'm able to reproduce it in my older Fedora too (F32) and I will look into it.

Comment 2 Fedora Update System 2021-02-22 07:45:45 UTC
FEDORA-2021-5be90ab004 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-5be90ab004

Comment 3 Fedora Update System 2021-02-22 08:03:10 UTC
FEDORA-2021-fb090f432a has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2021-fb090f432a

Comment 4 Peter Heatwole 2021-02-22 17:25:08 UTC
Hi Zdenek,

The new build looks good. Thanks!

Comment 5 Fedora Update System 2021-02-24 21:40:08 UTC
FEDORA-2021-fb090f432a has been pushed to the Fedora 32 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-fb090f432a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-fb090f432a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2021-02-24 21:55:28 UTC
FEDORA-2021-5be90ab004 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-5be90ab004`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-5be90ab004

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2021-02-26 01:09:29 UTC
FEDORA-2021-5be90ab004 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2021-03-08 20:14:12 UTC
FEDORA-2021-fb090f432a has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.