Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1933617 - F35FailsToInstall: python3-scrapy
Summary: F35FailsToInstall: python3-scrapy
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-scrapy
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Eduardo Echeverria
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1946030 1946033
Blocks: F35FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2021-03-01 09:41 UTC by Miro Hrončok
Modified: 2021-04-12 04:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-12 04:09:44 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2021-03-01 09:41:12 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (python-scrapy) Fails To Install in Fedora 35:

can't install python3-scrapy:
  - nothing provides python3.9dist(itemadapter) >= 0.1 needed by python3-scrapy-2.4.1-1.fc35.noarch
  - nothing provides python3.9dist(itemloaders) >= 1.0.1 needed by python3-scrapy-2.4.1-1.fc35.noarch
  - nothing provides python3.9dist(protego) >= 0.1.15 needed by python3-scrapy-2.4.1-1.fc35.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2021-03-08 22:19:49 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 2 Eduardo Echeverria 2021-03-14 16:39:03 UTC
This package is working well in all the branches, rawhide doesn't provide python 3.9?

Comment 3 Eduardo Echeverria 2021-03-14 17:04:43 UTC
https://koji.fedoraproject.org/koji/taskinfo?taskID=63765356 done

Comment 4 Miro Hrončok 2021-03-15 00:15:08 UTC
Rawhide provides python 3.9, but not the missing dependencies:

Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides python3.9dist(itemadapter) >= 0.1 needed by python3-scrapy-2.4.1-2.fc35.noarch
  - nothing provides python3.9dist(itemloaders) >= 1.0.1 needed by python3-scrapy-2.4.1-2.fc35.noarch
  - nothing provides python3.9dist(protego) >= 0.1.15 needed by python3-scrapy-2.4.1-2.fc35.noarch


A simple rebuild won't fix this. The package has missing *runtime* dependencies and fails to install after it was updated to 2.4.1.

Comment 5 Miro Hrončok 2021-03-31 11:55:25 UTC
Hello,

This is the second reminder (step 4 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 6 Eduardo Echeverria 2021-03-31 14:54:04 UTC
I'll try to fix it this Saturday, but I'm not sure how I need to proceed, do you have some advice?

Comment 7 Miro Hrončok 2021-03-31 15:05:39 UTC
The missing dependencies need to be packaged in Fedora or the update needs to be reverted with an epoch bump.

Comment 8 Eduardo Echeverria 2021-04-03 17:12:00 UTC
First dependency package https://bugzilla.redhat.com/show_bug.cgi?id=1946030

Comment 9 Eduardo Echeverria 2021-04-03 18:18:38 UTC
Second dependency package https://bugzilla.redhat.com/show_bug.cgi?id=1946033

Comment 10 Eduardo Echeverria 2021-04-03 18:57:39 UTC
Third and last dependency package: https://bugzilla.redhat.com/show_bug.cgi?id=1946041 (needs python3.9dist(jmespath) >= 0.9.5) Current fedora version is 0.9.4 and needs python-itemadapter (that is the first dependecy posted here)

Comment 11 Eduardo Echeverria 2021-04-08 02:42:31 UTC
Dependencies were packaged, sent to rawhide and package was rebuilt https://koji.fedoraproject.org/koji/taskinfo?taskID=65456511


Note You need to log in before you can comment on or make changes to this bug.