Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1933731 - USB keyboard does not work after boot on rpi4,8gb
Summary: USB keyboard does not work after boot on rpi4,8gb
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 34
Hardware: aarch64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: ARMTracker F34BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2021-03-01 15:12 UTC by François Kooman
Modified: 2021-03-06 05:36 UTC (History)
21 users (show)

Fixed In Version: kernel-5.11.3-300.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-06 05:36:05 UTC
Type: Bug


Attachments (Terms of Use)

Description François Kooman 2021-03-01 15:12:49 UTC
1. Please describe the problem:

rpi4,8gb USB keyboard does not work after (initial) boot.

tried with image: Fedora-Minimal-34-20210219.n.0.aarch64.raw.xz

2. What is the Version-Release number of the kernel:

whatever the version is in the above image.

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:

install above image on USB disk using arm-image-installer with target rpi4 and boot it.

Comment 1 Peter Robinson 2021-03-04 14:47:59 UTC
Should be fixed with 5.11.3

Comment 2 Paul Whalen 2021-03-04 21:18:51 UTC
Verified fixed in kernel-5.11.3-300.fc34.

Comment 3 Fedora Blocker Bugs Application 2021-03-04 21:54:58 UTC
Proposed as a Freeze Exception for 34-beta by Fedora user pbrobinson using the blocker tracking app because:

 Fixes USB on some variants of the Raspberry Pi 4 series

Comment 4 Fedora Update System 2021-03-04 22:18:44 UTC
FEDORA-2021-1521506068 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-1521506068

Comment 5 Adam Williamson 2021-03-05 22:16:53 UTC
+3 in https://pagure.io/fedora-qa/blocker-review/issue/281 , marking accepted.

Comment 6 Fedora Update System 2021-03-06 05:36:05 UTC
FEDORA-2021-1521506068 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.