Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1936147 - bcm283x-firmware update breaks booting on Raspberry Pi 3B+
Summary: bcm283x-firmware update breaks booting on Raspberry Pi 3B+
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bcm283x-firmware
Version: 34
Hardware: aarch64
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARMTracker F34BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2021-03-07 00:19 UTC by Tom Lane
Modified: 2021-03-19 20:15 UTC (History)
5 users (show)

Fixed In Version: bcm283x-firmware-20210310-1.0591568.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-19 20:15:37 UTC
Type: Bug


Attachments (Terms of Use)

Description Tom Lane 2021-03-07 00:19:24 UTC
Description of problem: 
Raspberry Pi 3B+ fails to boot after updating bcm283x-firmware and bcm283x-overlays to updates-testing version

Version-Release number of selected component (if applicable):
20210225-1.5985247.fc34

How reproducible:
100%

Steps to Reproduce:
1. Install current F34 (I did this by installing F33 and then using system-upgrade, since current F34 composes are broken for other reasons).
2. sudo yum update bcm283x-firmware bcm283x-overlays
(Apparently testing repo is active in current F34 images?  I didn't ask for it, anyway)
3. Reboot

Actual results:
Dead machine, no sign of U-Boot being functional at all, let alone GRUB

Expected results:
Normal boot

Additional info:
Things are OK with the 20210108-1.934252b.fc34.aarch64 releases.

I'm using an HDMI monitor with this, in case it matters.

Comment 1 Paul Whalen 2021-03-07 14:47:18 UTC
If you enable the serial console in config.txt, it should boot ok.

Comment 2 Fedora Update System 2021-03-14 22:12:20 UTC
FEDORA-2021-84510c6f65 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-84510c6f65

Comment 3 Fedora Blocker Bugs Application 2021-03-14 22:16:55 UTC
Proposed as a Freeze Exception for 34-beta by Fedora user pbrobinson using the blocker tracking app because:

 Improvements for USB support on some Raspberry Pi 4 devices, in particular the RPi-4B 8Gb edition, the new RPi-400 and Compute Module 4.

Comment 4 Adam Williamson 2021-03-15 15:55:00 UTC
If the bug is only in updates-testing, granting an FE can't improve matters any. The fix will already have replaced the broken version in updates-testing, and the broken version isn't in stable.

Comment 5 Peter Robinson 2021-03-15 17:14:50 UTC
(In reply to Adam Williamson from comment #4)
> If the bug is only in updates-testing, granting an FE can't improve matters
> any. The fix will already have replaced the broken version in
> updates-testing, and the broken version isn't in stable.

Sorry, I extrapolated that description badly, the firmware update which was in updates testing broke somethings which as you state was only in updates testing, but the firmware update itself fixes things in stable for "Improvements for USB support on some Raspberry Pi 4 devices, in particular the RPi-4B 8Gb edition, the new RPi-400 and Compute Module 4." plus the fix to the break that was in testing.

Comment 6 Geoffrey Marr 2021-03-15 20:55:24 UTC
Discussed during the 2021-03-15 blocker review meeting: [0]

The decision to delay the classification of this as a freeze exception was made as the bug proposed seems to be present only in updates-testing, so an FE is unnecessary. We'll ask Peter if he really wanted an FE for other improvements in the update, and reconsider if so.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2021-03-15/f34-blocker-review.2021-03-15-16.00.txt

Comment 7 Fedora Update System 2021-03-16 14:42:24 UTC
FEDORA-2021-84510c6f65 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-84510c6f65`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-84510c6f65

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Adam Williamson 2021-03-16 23:29:35 UTC
Peter: ah, we figured it was probably something like that. It's academic in any case as we weren't doing another RC for Beta, as things stand we'll be shipping RC2 unless we find a blocker between now and Thursday. If we do find a blocker I'll get this re-voted before we spin the next RC.

Comment 9 Fedora Update System 2021-03-19 20:15:37 UTC
FEDORA-2021-84510c6f65 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.