Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1940231 - FTI in Fedora 35: python3-uvicorn+standard
Summary: FTI in Fedora 35: python3-uvicorn+standard
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-uvicorn
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Carl George 🤠
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1931114
Blocks: F35FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2021-03-17 20:55 UTC by Ben Beasley
Modified: 2021-03-21 18:18 UTC (History)
3 users (show)

Fixed In Version: python-uvicorn-0.13.4-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-20 01:27:17 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github encode uvicorn pull 946 0 None closed Relax watchgod up bound 2021-03-20 01:22:31 UTC

Description Ben Beasley 2021-03-17 20:55:58 UTC
Description of problem:

The metapackage for the “standard” extra fails to install in Rawhide (F35).

Version-Release number of selected component (if applicable): 0.13.3-1.fc34


How reproducible:


Steps to Reproduce:
1. mock -r fedora-rawhide-x86_64 --clean
2. mock -r fedora-rawhide-x86_64 -i 'python3-uvicorn+standard'

Actual results:

Error: 
 Problem: conflicting requests
  - nothing provides (python3.9dist(watchgod) < 0.7 with python3.9dist(watchgod) >= 0.6) needed by python3-uvicorn+standard-0.13.3-1.fc34.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Expected results:

Successful installation

Additional info:

The watchgod package was updated in F35 yesterday: https://src.fedoraproject.org/rpms/python-watchgod/c/685bf6e3923233c96cbc89d2a3929fc4a0114e5d?branch=rawhide

Fix this by updating to 0.13.4 (https://bugzilla.redhat.com/show_bug.cgi?id=1931114), or if there is some reason to delay, relax the requirement in setup.py as upstream did in https://github.com/encode/uvicorn/pull/946.

Comment 1 Fedora Update System 2021-03-20 01:27:17 UTC
FEDORA-2021-e78c7c5cd7 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 2 Ben Beasley 2021-03-20 15:24:39 UTC
Thanks! I can build python-fastapi in Rawhide again now.

Comment 3 Carl George 🤠 2021-03-21 18:18:32 UTC
Of course, thanks for reporting the issue.


Note You need to log in before you can comment on or make changes to this bug.