Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1941336 - Unable to push to repository from eclipse
Summary: Unable to push to repository from eclipse
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-jgit
Version: 33
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Mat Booth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-21 17:11 UTC by Daniel
Modified: 2021-04-29 00:56 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-29 00:31:04 UTC
Type: Bug


Attachments (Terms of Use)

Description Daniel 2021-03-21 17:11:39 UTC
Description of problem:
Unable to push to repository from eclipse

Version-Release number of selected component (if applicable):
$ rpm -q jgit eclipse-egit eclipse-jgit
jgit-5.11.0-1.fc33.noarch
eclipse-egit-5.11.0-1.fc33.noarch
eclipse-jgit-5.11.0-1.fc33.noarch


How reproducible:
Everytime

Steps to Reproduce:
1. Push to github repository from eclipse
2.
3.

Actual results:
Eclipse shows an error about "remote hung up unexpectedly".

Expected results:
Eclipse should be able to push to github repository

Additional info:
The following log was in .metadata/.log
org.eclipse.jgit.errors.TransportException: git@github.com:username/project.git: remote hung up unexpectedly
	at org.eclipse.jgit.transport.TransportGitSsh$SshPushConnection.<init>(TransportGitSsh.java:383)
	at org.eclipse.jgit.transport.TransportGitSsh.openPush(TransportGitSsh.java:159)
	at org.eclipse.jgit.transport.PushProcess.execute(PushProcess.java:127)
	at org.eclipse.jgit.transport.Transport.push(Transport.java:1384)
	at org.eclipse.egit.core.op.PushOperation.run(PushOperation.java:191)
	at org.eclipse.egit.ui.internal.push.ConfirmationPage$2.run(ConfirmationPage.java:210)
	at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:122)
Caused by: java.lang.NoClassDefFoundError: Could not initialize class org.eclipse.jgit.internal.transport.sshd.CachingKeyPairProvider
	at org.eclipse.jgit.transport.sshd.SshdSessionFactory.lambda$getDefaultKeys$5(SshdSessionFactory.java:489)
	at java.base/java.util.concurrent.ConcurrentHashMap.computeIfAbsent(ConcurrentHashMap.java:1705)
	at org.eclipse.jgit.transport.sshd.SshdSessionFactory.getDefaultKeys(SshdSessionFactory.java:487)
	at org.eclipse.jgit.transport.sshd.SshdSessionFactory.lambda$getSession$1(SshdSessionFactory.java:202)
	at org.eclipse.jgit.transport.sshd.SshdSession.<init>(SshdSession.java:91)
	at org.eclipse.jgit.transport.sshd.SshdSessionFactory.getSession(SshdSessionFactory.java:186)
	at org.eclipse.jgit.transport.sshd.SshdSessionFactory.getSession(SshdSessionFactory.java:73)
	at org.eclipse.jgit.transport.SshTransport.getSession(SshTransport.java:107)
	at org.eclipse.jgit.transport.TransportGitSsh$SshPushConnection.<init>(TransportGitSsh.java:358)
	... 6 more

Comment 1 Fedora Admin user for bugzilla script actions 2021-03-24 00:21:20 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 2 Daniel 2021-03-29 03:14:25 UTC
I found another error in .metadata/.log

org.eclipse.jgit.api.errors.TransportException: git@github.com:username/project.git: remote hung up unexpectedly
	at org.eclipse.jgit.api.FetchCommand.call(FetchCommand.java:225)
	at org.eclipse.jgit.api.PullCommand.call(PullCommand.java:263)
	at org.eclipse.egit.core.op.PullOperation$PullJob.run(PullOperation.java:255)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)
Caused by: org.eclipse.jgit.errors.TransportException: git@github.com:username/project.git: remote hung up unexpectedly
	at org.eclipse.jgit.transport.TransportGitSsh$SshFetchConnection.<init>(TransportGitSsh.java:314)
	at org.eclipse.jgit.transport.TransportGitSsh.openFetch(TransportGitSsh.java:153)
	at org.eclipse.jgit.transport.FetchProcess.executeImp(FetchProcess.java:142)
	at org.eclipse.jgit.transport.FetchProcess.execute(FetchProcess.java:94)
	at org.eclipse.jgit.transport.Transport.fetch(Transport.java:1309)
	at org.eclipse.jgit.api.FetchCommand.call(FetchCommand.java:213)
	... 3 more
Caused by: java.lang.NoClassDefFoundError: org/slf4j/LoggerFactory
	at org.apache.sshd.common.util.security.SecurityUtils.register(SecurityUtils.java:424)
	at org.apache.sshd.common.util.security.SecurityUtils.createSecurityEntityFactory(SecurityUtils.java:716)
	at org.apache.sshd.common.util.security.SecurityUtils.lambda$resolveSecurityEntityFactory$1(SecurityUtils.java:708)
	at java.base/java.util.Map.computeIfAbsent(Map.java:1003)
	at org.apache.sshd.common.util.security.SecurityUtils.resolveSecurityEntityFactory(SecurityUtils.java:707)
	at org.apache.sshd.common.util.security.SecurityUtils.getMessageDigest(SecurityUtils.java:752)
	at org.apache.sshd.common.digest.DigestUtils.checkSupported(DigestUtils.java:53)
	at org.apache.sshd.common.digest.BuiltinDigests.<init>(BuiltinDigests.java:59)
	at org.apache.sshd.common.digest.BuiltinDigests.<clinit>(BuiltinDigests.java:36)
	at org.apache.sshd.common.cipher.ECCurves.<clinit>(ECCurves.java:61)
	at org.apache.sshd.common.keyprovider.KeyPairProvider.<clinit>(KeyPairProvider.java:63)
	at org.eclipse.jgit.transport.sshd.SshdSessionFactory.lambda$getDefaultKeys$5(SshdSessionFactory.java:489)
	at java.base/java.util.concurrent.ConcurrentHashMap.computeIfAbsent(ConcurrentHashMap.java:1705)
	at org.eclipse.jgit.transport.sshd.SshdSessionFactory.getDefaultKeys(SshdSessionFactory.java:487)
	at org.eclipse.jgit.transport.sshd.SshdSessionFactory.lambda$getSession$1(SshdSessionFactory.java:202)
	at org.eclipse.jgit.transport.sshd.SshdSession.<init>(SshdSession.java:91)
	at org.eclipse.jgit.transport.sshd.SshdSessionFactory.getSession(SshdSessionFactory.java:186)
	at org.eclipse.jgit.transport.sshd.SshdSessionFactory.getSession(SshdSessionFactory.java:73)
	at org.eclipse.jgit.transport.SshTransport.getSession(SshTransport.java:107)
	at org.eclipse.jgit.transport.TransportGitSsh$SshFetchConnection.<init>(TransportGitSsh.java:281)
	... 8 more
Caused by: java.lang.ClassNotFoundException: org.slf4j.LoggerFactory cannot be found by org.apache.sshd.osgi_2.6.0
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:519)
	at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:171)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:522)
	... 28 more

Comment 3 Fedora Update System 2021-04-21 10:52:25 UTC
FEDORA-2021-0ae66283c3 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-0ae66283c3

Comment 4 Fedora Update System 2021-04-21 11:01:39 UTC
FEDORA-2021-682daa1c52 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-682daa1c52

Comment 5 Fedora Update System 2021-04-21 15:01:46 UTC
FEDORA-2021-0ae66283c3 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-0ae66283c3`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-0ae66283c3

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2021-04-21 22:01:35 UTC
FEDORA-2021-682daa1c52 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-682daa1c52`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-682daa1c52

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Daniel 2021-04-22 02:27:26 UTC
Thank you very much for your response.
This fix solved my problem on Fedora 33.

Comment 8 Fedora Update System 2021-04-29 00:31:04 UTC
FEDORA-2021-0ae66283c3 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2021-04-29 00:56:37 UTC
FEDORA-2021-682daa1c52 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.