Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1941630 - lots of unmatched cron log entries
Summary: lots of unmatched cron log entries
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: logwatch
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Frank Crawford
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1943911 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-22 14:01 UTC by Tom Horsley
Modified: 2021-04-24 20:05 UTC (History)
8 users (show)

Fixed In Version: logwatch-7.5.5-2.fc33 logwatch-7.5.5-2.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-09 15:16:58 UTC
Type: Bug


Attachments (Terms of Use)

Description Tom Horsley 2021-03-22 14:01:40 UTC
Description of problem:
Since my last update I get unmatched cron entries in my logwatch report:

 --------------------- Cron Begin ------------------------ 

 **Unmatched Entries**
 CMDEND (/zooty/ip/update-my-ip)
 CMDEND (/usr/bin/fetchmail -s >> $HOME/.fetchmail.log 2>&1)
 CMDEND (run-parts /etc/cron.hourly/)
...


Version-Release number of selected component (if applicable):
logwatch-7.5.5-1.fc33.noarch
cronie-1.5.6-1.fc33.x86_64


How reproducible:
I'm guessing 100%

Steps to Reproduce:
1.setup logwatch
2.observe the mail with all the irritating CMDEND lines
3.

Actual results:
excess blather in logwatch mail

Expected results:
only useful info in logwatch mail

Additional info:

Comment 1 Frank Crawford 2021-03-23 11:15:44 UTC
This appears to be a change in cronie.  Prior to 1.5.6 it did not print CMDEND, but the latest version does.

I will look at a quick fix to suppress it, but a full fix probably won't be available until the next release of logwatch, in about 6 months.

Comment 2 Tom Horsley 2021-03-25 14:18:57 UTC
I just went into /usr/share/logwatch/scripts/services/cron and added this test immediately after the CMD matching:

      } elsif $ThisLine =~ s/^CMDEND \((.+)\)\s*$/$1/) {
         # ignore

I'll see if it works tomorrow when I get my next logwatch run.

Comment 3 Frank Crawford 2021-03-26 08:00:28 UTC
Tom, thanks.

You can actually get it dropped by adding it to the block of lines ending in a '# Ignore' near the start of the script, and that is likely to be the quick fix.

However, I may also look at if we may report on the data at a later stage.

Comment 4 Frank Crawford 2021-03-29 11:26:53 UTC
*** Bug 1943911 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2021-04-06 11:33:31 UTC
FEDORA-2021-7a2e153f33 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-7a2e153f33

Comment 6 Fedora Update System 2021-04-06 11:46:02 UTC
FEDORA-2021-42021ae95f has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-42021ae95f

Comment 7 Fedora Update System 2021-04-06 11:55:57 UTC
FEDORA-2021-7a40bc0b7e has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2021-7a40bc0b7e

Comment 8 Fedora Update System 2021-04-07 15:19:57 UTC
FEDORA-2021-42021ae95f has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-42021ae95f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-42021ae95f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2021-04-07 15:58:22 UTC
FEDORA-2021-7a40bc0b7e has been pushed to the Fedora 32 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-7a40bc0b7e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-7a40bc0b7e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2021-04-07 18:14:59 UTC
FEDORA-2021-7a2e153f33 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-7a2e153f33`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-7a2e153f33

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2021-04-09 15:16:58 UTC
FEDORA-2021-42021ae95f has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Fedora Update System 2021-04-15 14:53:40 UTC
FEDORA-2021-7a40bc0b7e has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 Fedora Update System 2021-04-24 19:44:37 UTC
FEDORA-2021-7a2e153f33 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Fedora Update System 2021-04-24 20:05:01 UTC
FEDORA-2021-7a2e153f33 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.