Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1942422 - F35FailsToInstall: simde-devel
Summary: F35FailsToInstall: simde-devel
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: simde
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jun Aruga
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F35FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2021-03-24 10:49 UTC by Miro Hrončok
Modified: 2021-03-24 23:20 UTC (History)
2 users (show)

Fixed In Version: simde-0.0.0-10.git396e05c.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-24 23:20:43 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Removes %{?_isa} from Requires on hedley-static (deleted)
2021-03-24 18:58 UTC, Ben Beasley
no flags Details | Diff

Description Miro Hrončok 2021-03-24 10:49:11 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (simde) Fails To Install in Fedora 35:

can't install simde-devel:
  - nothing provides hedley-static(x86-64) needed by simde-devel-0.0.0-9.git396e05c.fc35.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Jun Aruga 2021-03-24 18:28:01 UTC
Oh I confirmed the installation error.

```
$ mock -i simde-devel-0.0.0-9.git396e05c.fc35.x86_64.rpm
...
Error: 
 Problem: conflicting requests
  - nothing provides hedley-static(x86-64) needed by simde-devel-0.0.0-9.git396e05c.fc35.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
ERROR: Command failed: 
 # /usr/bin/systemd-nspawn -q -M 2813fa54988e4566a9633eb81ef43a51 -D /var/lib/mock/fedora-rawhide-x86_64-bootstrap/root -a --capability=cap_ipc_lock --bind=/tmp/mock-resolv.tp5_6hr0:/etc/resolv.conf --console=pipe --setenv=TERM=vt100 --setenv=SHELL=/bin/bash --setenv=HOME=/var/lib/mock/fedora-rawhide-x86_64/root/installation-homedir --setenv=HOSTNAME=mock --setenv=PATH=/usr/bin:/bin:/usr/sbin:/sbin --setenv=PROMPT_COMMAND=printf "\033]0;<mock-chroot>\007" --setenv=PS1=<mock-chroot> \s-\v\$  --setenv=LANG=C.UTF-8 --setenv=LC_MESSAGES=C.UTF-8 --resolv-conf=off /usr/bin/dnf --installroot /var/lib/mock/fedora-rawhide-x86_64/root/ --releasever 33 --setopt=deltarpm=False --allowerasing --disableplugin=local --disableplugin=spacewalk install /builddir/simde-devel-0.0.0-9.git396e05c.fc35.x86_64.rpm --setopt=tsflags=nocontexts
```

Hi Benjamin, do you know that's the reason of this error? I can see the build and hedley-static. Thanks.
https://src.fedoraproject.org/rpms/hedley
https://koji.fedoraproject.org/koji/buildinfo?buildID=1724289
https://src.fedoraproject.org/rpms/hedley/blob/rawhide/f/hedley.spec#_28
> Provides: %{name}-static = %{version}-%{release}

Comment 2 Jun Aruga 2021-03-24 18:40:44 UTC
I see the following packages are required.
Apart from the main topic, I think requiring clang, cmake, gcc, gcc-c++, make is wrong. These could be optional.

```
$ rpm -qRp simde-0.0.0-9.git396e05c.fc35.src.rpm
clang
cmake
gcc
gcc-c++
hedley-devel
hedley-static
make
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
```

Comment 3 Jun Aruga 2021-03-24 18:53:48 UTC
I opened the PR here.
https://src.fedoraproject.org/rpms/simde/pull-request/5

Comment 4 Ben Beasley 2021-03-24 18:57:17 UTC
My apologies; this is due to a defect in my original PR unbundling hedley. The Requires on hedley-static should not have been arched, as the virtual Provides specified in https://docs.fedoraproject.org/en-US/packaging-guidelines/#_packaging_header_only_libraries is not arched. (Please don’t remove this Requires entirely as in the PR above, as that conflicts with the linked Guidelines).

I don’t seem to be able to prepare a new PR due to Pagure flakiness I’m attributing to the FAS upgrade in progress, so I’ll upload a patch.

Comment 5 Ben Beasley 2021-03-24 18:58:21 UTC
Created attachment 1766008 [details]
Removes %{?_isa} from Requires on hedley-static

Comment 6 Jun Aruga 2021-03-24 19:15:51 UTC
> My apologies; this is due to a defect in my original PR unbundling hedley. The Requires on hedley-static should not have been arched, as the virtual Provides specified in https://docs.fedoraproject.org/en-US/packaging-guidelines/#_packaging_header_only_libraries is not arched. (Please don’t remove this Requires entirely as in the PR above, as that conflicts with the linked Guidelines).
> 
> I don’t seem to be able to prepare a new PR due to Pagure flakiness I’m attributing to the FAS upgrade in progress, so I’ll upload a patch.

Thank you for your quick response and the patch! I will use your patch.

> The Requires on hedley-static should not have been arched

OK. That was the cause of the error. Thank you for the clarifying it. The Fedora simde repo started to use Zuul CI that check the installation of the RPMs on the pull-request timing. So, next time we will not see this kind of issue :)

Comment 7 Jun Aruga 2021-03-24 23:20:43 UTC
This issue was fixed! Thanks!


Note You need to log in before you can comment on or make changes to this bug.