Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1943697 - SELinux is preventing f2b/f.selinux-s from 'watch' accesses on the dossier /run/log/journal.
Summary: SELinux is preventing f2b/f.selinux-s from 'watch' accesses on the dossier /r...
Keywords:
Status: CLOSED DUPLICATE of bug 1943696
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 34
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:950dd16deac4cf2aecaa48057c6...
: 1943786 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-26 20:12 UTC by Nicolas Berrehouc
Modified: 2022-01-26 17:09 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-01-26 17:09:51 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Nicolas Berrehouc 2021-03-26 20:12:46 UTC
Description of problem:
After upgrading from F33 to F34 Beta.
SELinux is preventing f2b/f.selinux-s from 'watch' accesses on the dossier /run/log/journal.

*****  Plugin catchall (100. confidence) suggests   **************************

Si vous pensez que f.selinux-s devrait être autorisé à accéder watch sur journal directory par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# ausearch -c "f2b/f.selinux-s" --raw | audit2allow -M my-f2bfselinuxs
# semodule -X 300 -i my-f2bfselinuxs.pp

Additional Information:
Source Context                system_u:system_r:fail2ban_t:s0
Target Context                system_u:object_r:syslogd_var_run_t:s0
Target Objects                /run/log/journal [ dir ]
Source                        f2b/f.selinux-s
Source Path                   f2b/f.selinux-s
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
SELinux Policy RPM            selinux-policy-targeted-3.14.7-27.fc34.noarch
Local Policy RPM              selinux-policy-targeted-3.14.7-27.fc34.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.11.9-300.fc34.x86_64 #1 SMP Wed
                              Mar 24 12:06:51 UTC 2021 x86_64 x86_64
Alert Count                   1
First Seen                    2021-03-26 21:05:38 CET
Last Seen                     2021-03-26 21:05:38 CET
Local ID                      cd09a138-0b2e-4367-b7fb-b34d610ef81f

Raw Audit Messages
type=AVC msg=audit(1616789138.917:526): avc:  denied  { watch } for  pid=814 comm="f2b/f.selinux-s" path="/run/log/journal" dev="tmpfs" ino=55 scontext=system_u:system_r:fail2ban_t:s0 tcontext=system_u:object_r:syslogd_var_run_t:s0 tclass=dir permissive=0


Hash: f2b/f.selinux-s,fail2ban_t,syslogd_var_run_t,dir,watch

Version-Release number of selected component:
selinux-policy-targeted-3.14.7-27.fc34.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.14.0
hashmarkername: setroubleshoot
kernel:         5.11.9-300.fc34.x86_64
type:           libreport

Comment 1 Zdenek Pytela 2021-03-31 19:12:13 UTC
*** Bug 1943786 has been marked as a duplicate of this bug. ***

Comment 2 Zdenek Pytela 2022-01-26 17:09:51 UTC

*** This bug has been marked as a duplicate of bug 1943696 ***


Note You need to log in before you can comment on or make changes to this bug.