Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1945950 - dracut-053 renders system unbootable
Summary: dracut-053 renders system unbootable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: 34
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: dracut-maint-list
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1948077 1948125 1948193 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-02 21:16 UTC by Oyvind Saether
Modified: 2021-04-14 13:46 UTC (History)
10 users (show)

Fixed In Version: dracut-053-2.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-13 01:34:30 UTC
Type: Bug


Attachments (Terms of Use)

Description Oyvind Saether 2021-04-02 21:16:46 UTC
1) Have Fedora 34.
2) "Upgrade" to dracut dracut-053
3) Build kernel
4) Reboot and have it wait for something like starting root and swap forever

dracut-051 did not render the system unbootable (I am fairly sure I built a kernel or two with that one before "upgrading" to the broken -053 version.

dnf downgrade dracut didn't work for some reason. I did, luckily, have a box with dracut-050 on it so I managed to solve it by copying 
/usr/lib/dracut/modules.d/ from that box onto the ones with dracut-053.

That it works with a /usr/lib/dracut/modules.d/ folder from -050 (and that it also works with 051) makes it evident that something within /usr/lib/dracut/modules.d/ changed between dracut-051 and dracut-053 that results in unbootable systems. I am not sure if it's because my root / is RAID1 or if it's because I use LVM or what the cause is, all I know is that I'll probably have to extract the tarball I made of /usr/lib/dracut/modules.d/ from -050 every time a new dracut "upgrade" is made. That's a bit unfortunate. This bug is also a bit unfortunate since most will probably not be able to solve this and get a bootable system.

Comment 1 Ade Bradshaw 2021-04-03 10:44:42 UTC
I have the same issue, I upgraded my F33 laptop to F34 - first boot hangs on "running start job for .." both root and swap file systems. Reverting to the F33 grub entry works. 

I did a dnf update after booting and now I have 2 entries in grub that are F34 and one that is F33  - both the F34 entries result in an un-bootable system -  so I agree it seems dracut it broken

Comment 2 Throwaway Name 2021-04-03 21:56:39 UTC
Possibly a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1945596

Comment 4 Chris Murphy 2021-04-04 04:28:16 UTC
OK never mind, as figured out in bug 1945596, this is the fix.

https://github.com/dracutdevs/dracut/commit/ba4bcf5f4f11ad624c647ddf4f566997186135e7

Comment 5 Fedora Update System 2021-04-09 17:25:22 UTC
FEDORA-2021-50707f8501 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-50707f8501

Comment 6 digger vermont 2021-04-11 18:48:43 UTC
This works for me. However it still leaves any kernel that was installed with the previous version of dracut unbootable. There may be a simpler way but I boot with an earlier kernel, uninstall the latest kernel-core pkg, and then upgraded to reinstall it again.

Maybe I could have just "sudo dnf reinstall kernel-core" to do the same thing.

I hope that makes sense.

Comment 7 Chris Murphy 2021-04-11 19:02:07 UTC
(In reply to digger vermont from comment #6)
> This works for me. However it still leaves any kernel that was installed
> with the previous version of dracut unbootable.

That's expected. The bug in dracut is passed into the initramfs it creates. You have to both update dracut and then replace the initramfs, e.g.

sudo dracut -f /boot/initramfs-5.11.11-300.fc34.x86_64.img 5.11.11-300.fc34.x86_64

Comment 8 Oyvind Saether 2021-04-11 19:04:30 UTC
> Maybe I could have just "sudo dnf reinstall kernel-core" to do the same
> thing.
> 
> I hope that makes sense.

You can demand that dracut re-generated the initramfs for any old kernel you have with:

dracut --force --kver 5.11.12-300.fc34.x86_64

Just replace the --kver argument with thatever kernel argument. You can also specify a specific initramfs file and kernel version instead of using the --kver shortcut to use the default initramfs location.

Comment 9 digger vermont 2021-04-11 19:11:41 UTC
(In reply to Oyvind Saether from comment #8)

> 
> You can demand that dracut re-generated the initramfs for any old kernel you
> have with:
> 
> dracut --force --kver 5.11.12-300.fc34.x86_64
> 
> Just replace the --kver argument with thatever kernel argument. You can also
> specify a specific initramfs file and kernel version instead of using the
> --kver shortcut to use the default initramfs location.

Thanks, that's better than what I did and good to know. Since the previous version of dracut rendered kernels installed with it unbootable, should a post-install script for dracut include lines to regenerate at least the last installed kernel's initramfs?

Comment 10 Fedora Update System 2021-04-13 01:34:30 UTC
FEDORA-2021-50707f8501 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Justin M. Forbes 2021-04-14 13:42:42 UTC
*** Bug 1948193 has been marked as a duplicate of this bug. ***

Comment 12 Justin M. Forbes 2021-04-14 13:45:24 UTC
*** Bug 1948077 has been marked as a duplicate of this bug. ***

Comment 13 Justin M. Forbes 2021-04-14 13:46:03 UTC
*** Bug 1948125 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.