Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1947634 - Missing dependency on xz
Summary: Missing dependency on xz
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: arm-image-installer
Version: 33
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-08 19:00 UTC by Tom Rini
Modified: 2021-04-22 14:53 UTC (History)
2 users (show)

Fixed In Version: arm-image-installer-3.4-1.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-22 14:53:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Tom Rini 2021-04-08 19:00:16 UTC
Description of problem:

The arm-image-installer script uses "xzcat" to decompress the xz file passed with --image but does not depend on xz being installed

Version-Release number of selected component (if applicable):

3.1-1.fc33

How reproducible:

Run:
arm-image-installer --image=Fedora-Rawhide.xz --target=Bananapi --media=/dev/mmcblk0

Without "xz" installed on the system.

Actual results:

...
/usr/bin/arm-image-installer: line 313: xzcat: command not found
0+0 records in
0+0 records out
0 bytes copied, 3.9945e-05 s, 0.0 kB/s
= Writing image complete!

Comment 1 Tom Rini 2021-04-08 20:07:05 UTC
There is also a missing dependency on libselinux-utils, to provide getenforce which is called to see if relabeling is required.  Since both of these missing deps are rather common a Fedora install, I should note that my use case is "I don't have Fedora installed, let me throw it in a container so I can put Fedora on some ARM SBCs I have handy".

Comment 2 Peter Robinson 2021-04-19 15:28:13 UTC
And xfsprogs if you're using the Server image.

Comment 3 Fedora Update System 2021-04-19 16:42:29 UTC
FEDORA-2021-6b01add75e has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-6b01add75e

Comment 4 Fedora Update System 2021-04-20 22:25:13 UTC
FEDORA-2021-6b01add75e has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-6b01add75e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-6b01add75e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2021-04-21 18:20:45 UTC
FEDORA-2021-6b01add75e has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-6b01add75e

Comment 6 Fedora Update System 2021-04-22 14:53:39 UTC
FEDORA-2021-6b01add75e has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.