Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1947952 - Boot with fc34 kernels hangs
Summary: Boot with fc34 kernels hangs
Keywords:
Status: CLOSED DUPLICATE of bug 1946074
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 34
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-09 15:13 UTC by Horst H. von Brand
Modified: 2021-04-09 17:01 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-09 17:01:23 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Boot log (87.43 KB, text/plain)
2021-04-09 15:13 UTC, Horst H. von Brand
no flags Details

Description Horst H. von Brand 2021-04-09 15:13:13 UTC
Created attachment 1770668 [details]
Boot log

1. Please describe the problem:

Boot fails with fc34 kernels after update from 33. It hangs at:
"A start job is running for /dev/mapper/fedora-root" and
"A start job is running for /dev/mapper/fedora-swap"

2. What is the Version-Release number of the kernel:

kernel-5.11.12-300.fc34.x86_64 (same with kernel-5.11.11-300.fc34.x86_64)

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

It works fine with kernel-5.11.11-200.fc33.x86_64

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:

Boot.

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:

I get: "Error: Unknown repo: 'rawhide'"

6. Are you running any modules that not shipped with directly Fedora's kernel?:
No.

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Comment 1 Horst H. von Brand 2021-04-09 15:36:35 UTC
Sorry, pilot error.

Rawhide kernel kernel-5.12.0-0.rc6.20210407git2d743660786e.185.fc35.x86_64 gives the same hang

Comment 2 Justin M. Forbes 2021-04-09 17:01:23 UTC
This is not kernel, it is dracut. https://bodhi.fedoraproject.org/updates/FEDORA-2021-50707f8501 should fix it.  You will have to generate a new initramfs after the dracut upgrade.

*** This bug has been marked as a duplicate of bug 1946074 ***


Note You need to log in before you can comment on or make changes to this bug.