Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1948945 - python-aiosmtpd: FTBFS in Fedora rawhide
Summary: python-aiosmtpd: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-aiosmtpd
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard: AcceptedFreezeException
: 1968887 2006274 (view as bug list)
Depends On:
Blocks: PYTHON3.10 F35BetaFreezeException 1900668 F35FTBFS F35FailsToInstall F36FTBFS
TreeView+ depends on / blocked
 
Reported: 2021-04-13 06:46 UTC by Tomáš Hrnčiar
Modified: 2021-09-24 20:32 UTC (History)
4 users (show)

Fixed In Version: python-aiosmtpd-1.4.2-6.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-24 20:32:55 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github aio-libs aiosmtpd issues 277 0 None open aiosmtpd test suite fails on Python 3.10 2021-07-27 12:19:34 UTC

Description Tomáš Hrnčiar 2021-04-13 06:46:02 UTC
Description of problem:
Package python-aiosmtpd fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
1.4.2-1.fc35

Steps to Reproduce:
koji build --scratch f35 python-aiosmtpd-1.4.2-1.fc35.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-aiosmtpd

Comment 1 Miro Hrončok 2021-06-04 20:15:20 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 2 Miro Hrončok 2021-06-07 22:59:47 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 3 Miro Hrončok 2021-06-08 11:21:18 UTC
*** Bug 1968887 has been marked as a duplicate of this bug. ***

Comment 4 Miro Hrončok 2021-06-15 20:26:41 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 5 Miro Hrončok 2021-07-07 11:36:42 UTC
Hello,

This is the second reminder (step 4 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 6 Fedora Release Engineering 2021-07-11 04:22:43 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 35.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-06-08).

A week before the mass branching of Fedora 36 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 34 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-36/f-36-key-tasks.html

Comment 7 Neal Gompa 2021-07-27 12:19:35 UTC
Reported the issue upstream: https://github.com/aio-libs/aiosmtpd/issues/277

Comment 8 Ben Cotton 2021-08-10 12:58:46 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 9 Miro Hrončok 2021-09-13 09:21:53 UTC
Neal, upstream is clearly dormant. Should we retire this (and mailman3) from Fedora 35 until it is fixed? Having it in the repo when it cannot be installed adds no value.

Comment 10 Neal Gompa 2021-09-13 20:58:47 UTC
(In reply to Miro Hrončok from comment #9)
> Neal, upstream is clearly dormant. Should we retire this (and mailman3) from
> Fedora 35 until it is fixed? Having it in the repo when it cannot be
> installed adds no value.

Well, it only fails with the test suite, so we could just allow the test suite to fail, which would allow it to be built and installable...

Comment 11 Miro Hrončok 2021-09-14 10:57:51 UTC
If the problems don't block mailman, I suggest skipping the failing tests then.

Comment 12 Miro Hrončok 2021-09-17 11:05:00 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 36.

Thanks for taking care of it!

Comment 13 Miro Hrončok 2021-09-17 11:05:38 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 35.

Thanks for taking care of it!

Comment 14 Miro Hrončok 2021-09-17 11:17:08 UTC
Reopening so the update can close this once ready.

Comment 15 Miro Hrončok 2021-09-21 10:39:32 UTC
I suppose the intention was to create a joined F35 update with mailman3. CWould you consider creating the aiosmtpd update and adding mailman3 to it later if you manage to build it?

Comment 16 Miro Hrončok 2021-09-21 11:38:33 UTC
*** Bug 2006274 has been marked as a duplicate of this bug. ***

Comment 17 Neal Gompa 2021-09-21 12:53:04 UTC
(In reply to Miro Hrončok from comment #15)
> I suppose the intention was to create a joined F35 update with mailman3.
> CWould you consider creating the aiosmtpd update and adding mailman3 to it
> later if you manage to build it?

Yes, that's the plan. Once I get aiosmtpd and mailman3 going, I will submit an update with aiosmtpd, alembic, and mailman3 together.

Comment 18 Adam Williamson 2021-09-21 22:35:28 UTC
+4 in https://pagure.io/fedora-qa/blocker-review/issue/469 , marking accepted.

Comment 19 Fedora Update System 2021-09-23 15:07:48 UTC
FEDORA-2021-1eb02fcffb has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-1eb02fcffb

Comment 20 Fedora Update System 2021-09-24 20:32:55 UTC
FEDORA-2021-1eb02fcffb has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.