Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1955013 - missing libreoffice-langpack-fy for libreoffice
Summary: missing libreoffice-langpack-fy for libreoffice
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 34
Hardware: Unspecified
OS: All
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-29 09:20 UTC by tjipke
Modified: 2021-05-16 02:27 UTC (History)
4 users (show)

Fixed In Version: libreoffice-7.1.2.2-3.fc35 libreoffice-7.1.2.2-3.fc34 libreoffice-stable-3420210506100353.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-05 01:22:17 UTC
Type: Bug


Attachments (Terms of Use)

Description tjipke 2021-04-29 09:20:12 UTC
Description of problem:
When opening libreoffice on fedora 34,the language that has been selected when installing fedora has not been installed for libreoffice.

The version of libreoffice that has been installed by default is 7.1.2.2, and by taking a closer look at libreoffice translations and other distributions, translations for libreoffice in this language do exist.


How reproducible:
When installing fedora, select the "western frisian" language. 

Actual results:
Libreoffice is installed, but not available in the same language as selected for the system.

Expected results:
The expected result, is that either libreoffice installs the correct language pack (libreoffice-langpack-fy) by default, or allows me to install it after setting up the operating system.


Additional info:
these are all the libreoffice language packs that are in the repositories for fedora:
libreoffice-langpack-af.x86_64
libreoffice-langpack-ar.x86_64
libreoffice-langpack-as.x86_64
libreoffice-langpack-bg.x86_64
libreoffice-langpack-bn.x86_64
libreoffice-langpack-br.x86_64
libreoffice-langpack-ca.x86_64
libreoffice-langpack-cs.x86_64
libreoffice-langpack-cy.x86_64
libreoffice-langpack-da.x86_64
libreoffice-langpack-de.x86_64
libreoffice-langpack-dz.x86_64
libreoffice-langpack-el.x86_64
libreoffice-langpack-en.x86_64
libreoffice-langpack-eo.x86_64
libreoffice-langpack-es.x86_64
libreoffice-langpack-et.x86_64
libreoffice-langpack-eu.x86_64
libreoffice-langpack-fa.x86_64
libreoffice-langpack-fi.x86_64
libreoffice-langpack-fr.x86_64
libreoffice-langpack-ga.x86_64
libreoffice-langpack-gl.x86_64
libreoffice-langpack-gu.x86_64
libreoffice-langpack-he.x86_64
libreoffice-langpack-hi.x86_64
libreoffice-langpack-hr.x86_64
libreoffice-langpack-hu.x86_64
libreoffice-langpack-id.x86_64
libreoffice-langpack-it.x86_64
libreoffice-langpack-ja.x86_64
libreoffice-langpack-kk.x86_64
libreoffice-langpack-kn.x86_64
libreoffice-langpack-ko.x86_64
libreoffice-langpack-lt.x86_64
libreoffice-langpack-lv.x86_64
libreoffice-langpack-mai.x86_64
libreoffice-langpack-ml.x86_64
libreoffice-langpack-mr.x86_64
libreoffice-langpack-nb.x86_64
libreoffice-langpack-nl.x86_64
libreoffice-langpack-nn.x86_64
libreoffice-langpack-nr.x86_64
libreoffice-langpack-nso.x86_64
libreoffice-langpack-or.x86_64
libreoffice-langpack-pa.x86_64
libreoffice-langpack-pl.x86_64
libreoffice-langpack-pt-BR.x86_64
libreoffice-langpack-pt-PT.x86_64
libreoffice-langpack-ro.x86_64
libreoffice-langpack-ru.x86_64
libreoffice-langpack-si.x86_64
libreoffice-langpack-sk.x86_64
libreoffice-langpack-sl.x86_64
libreoffice-langpack-sr.x86_64
libreoffice-langpack-ss.x86_64
libreoffice-langpack-st.x86_64
libreoffice-langpack-sv.x86_64
libreoffice-langpack-ta.x86_64
libreoffice-langpack-te.x86_64
libreoffice-langpack-th.x86_64
libreoffice-langpack-tn.x86_64
libreoffice-langpack-tr.x86_64
libreoffice-langpack-ts.x86_64
libreoffice-langpack-uk.x86_64
libreoffice-langpack-ve.x86_64
libreoffice-langpack-xh.x86_64
libreoffice-langpack-zh-Hans.x86_64
libreoffice-langpack-zh-Hant.x86_64
libreoffice-langpack-zu.x86_64

I hope this is the correct way to make such a request, I'd gladly offer any additional information if required.

Comment 1 Caolan McNamara 2021-04-29 11:02:26 UTC
The translation seems to be flagged as useful. Checking what dependencies are available for a fy langpack: hunspell-fy, but no mythes-fy or hyphen-fy. fy does seem to have an autotext but not an autocorr and its help is marked as not usefully translatable. fc-list -v shows "fy" as a common lang: in fonts so that needs no special handling. Lets try building this langpack in rawhide first.

Comment 2 Fedora Update System 2021-04-30 18:54:35 UTC
FEDORA-2021-574ebdc943 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 3 Caolan McNamara 2021-04-30 19:58:58 UTC
will build for F34 also after w/e

Comment 4 Fedora Update System 2021-05-02 19:53:08 UTC
FEDORA-2021-1bb0c19d8d has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-1bb0c19d8d

Comment 5 Fedora Update System 2021-05-03 02:36:58 UTC
FEDORA-2021-1bb0c19d8d has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-1bb0c19d8d`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-1bb0c19d8d

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2021-05-05 01:22:17 UTC
FEDORA-2021-1bb0c19d8d has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Fedora Update System 2021-05-07 07:16:59 UTC
FEDORA-FLATPAK-2021-d7af823469 has been submitted as an update to Fedora 34 Flatpaks. https://bodhi.fedoraproject.org/updates/FEDORA-FLATPAK-2021-d7af823469

Comment 8 Fedora Update System 2021-05-08 02:18:51 UTC
FEDORA-FLATPAK-2021-d7af823469 has been pushed to the Fedora 34 Flatpaks testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-FLATPAK-2021-d7af823469

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2021-05-16 02:27:03 UTC
FEDORA-FLATPAK-2021-d7af823469 has been pushed to the Fedora 34 Flatpaks stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.