Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1955993 - clash with xfce4-screensaver - its unlock screen does not accept input
Summary: clash with xfce4-screensaver - its unlock screen does not accept input
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xscreensaver
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-02 00:33 UTC by René Genz
Modified: 2021-05-18 21:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-17 11:10:08 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description René Genz 2021-05-02 00:33:23 UTC
Description of problem:
In an Xfce session simultaneous use of xscreensaver and xfce4-screensaver can result in xfce4-screensaver lock screen not accepting password input.
Users must restart computer to unock. Super users can kill the xfce4-screensaver process (with TTY or SSH session) to unlock session.

Fedora 32->34 upgrade gets both packages installed (xscreensaver present, xfce4-screensaver installed in addition).

Version-Release number of selected component (if applicable):
xscreensaver-base-6.00-1.fc34.x86_64
xfce4-screensaver-4.16.0-2.fc34.x86_64

How reproducible:
100%

Steps to Reproduce:
### F32->F34 upgrade leads to installation of both packages
1. install Fedora 32 (I used netinstall ISO); at software selection screen: 
 Base Environment=Xfce Desktop
 Add-Ons for Selected Environment=default selection (empty)
2. status in F32:
$ rpm -q xscreensaver-base xfce4-screensaver
xscreensaver-base-5.45-1.fc32.x86_64
package xfce4-screensaver is not installed
3. prepare upgrade as root in terminal: dnf install -y dnf-plugin-system-upgrade; dnf update -y --refresh ; reboot
4. start upgrade as root in terminal: dnf system-upgrade download -y --releasever=34 ; dnf system-upgrade reboot
5. status in F34:
$ rpm -q xscreensaver-base xfce4-screensaver
xscreensaver-base-6.00-1.fc34.x86_64
xfce4-screensaver-4.16.0-2.fc34.x86_64
$ ps ax | grep screen
   1289 ?        Ssl    0:00 /usr/bin/xfce4-screensaver
   1440 ?        S      0:00 xscreensaver -no-splash
   1486 ?        S      0:00 xscreensaver-systemd
...

### the "xfce4-screensaver lock screen does not accept password input" part (regular F34 Xfce install is sufficient)
1. dnf install -y xscreensaver-base xfce4-screensaver ; reboot
2. log in as user and set idle timer to low values to speed up testing, f.i.:
- xfce4-screensaver-preferences -- Screensaver -- Regard the computer as idle after: 2 minute
- xscreensaver-settings -- Display Modes -- Blank After "1" minutes
3. close both windows and double check settings; xfce4-screensaver-preferences might stick to 5 minutes; if so, set xscreensaver-settings to 4 minutes
4. wait for idle times to expire


Actual results:
If xscreensaver locks before xfce4-screensaver and both are locked, you can unlock both (first xscreensaver, then xfce4-screensaver).

If xscreensaver locks before xfce4-screensaver and both are locked and you unlock xscreensaver but leave xfce4-xscreensaver locked and you wait for xscreensaver to lock again, password input is not accepted by xfce4-screensaver.

If xfce4-screensaver locks before xscreensaver and both are locked, you cannot unlock xfce4-screensaver. Password input is not accepted.


Expected results:
Either Do not start xscreensaver if xfce4-screensaver is installed (add "/usr/bin/xfce4-screensaver" exclusion to /usr/libexex/xscreensaver-autostart).
(the following 2 must be solved in other packages, I guess)
Or: independent of order, both screensavers can be unlocked.
Or: "uninstall xscreensaver on upgrade to Fedora 34".


Additional info:
Default Fedora 34 Xfce installation from scratch installs xfce4-screensaver, xscreensaver is not installed.

This comment https://fedoramagazine.org/announcing-fedora-34/#comment-514636
is related if xfce4-screensaver and xscreensaver is installed and this is set:
xfce4-screensaver-preferences -- Lock Screen -- [x] Lock Screen with System Sleep
To reproduce: suspend your computer and wake it up.

Comment 1 Fedora Update System 2021-05-03 14:16:06 UTC
FEDORA-2021-32c3bc6a3f has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-32c3bc6a3f

Comment 2 Fedora Update System 2021-05-04 01:09:10 UTC
FEDORA-2021-32c3bc6a3f has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-32c3bc6a3f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-32c3bc6a3f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2021-05-05 01:51:07 UTC
FEDORA-2021-7140ac3ac5 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-7140ac3ac5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-7140ac3ac5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2021-05-06 01:58:20 UTC
FEDORA-2021-c2e2cc1e9a has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-c2e2cc1e9a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-c2e2cc1e9a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 René Genz 2021-05-06 09:14:05 UTC
I installed the update and xscreensaver still got started. I found out that package xfce4-session provides xscreensaver autostart, see bug 1957658.

Comment 6 Fedora Update System 2021-05-14 17:49:16 UTC
FEDORA-2021-c2e2cc1e9a has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Alexei Podtelezhnikov 2021-05-18 12:14:46 UTC
This ERRATA does not fix anything. Still impossible to unlock.

Comment 8 Mamoru TASAKA 2021-05-18 13:34:59 UTC
Fix for xscreensaver side is pushed with this errata. But now xfce4-screensaver side needs fixing anyway.
So _this_ bug is fixed.

Comment 9 Alexei Podtelezhnikov 2021-05-18 14:35:01 UTC
Is "clash with xfce4-screensaver - its unlock screen does not accept input" fixed? 

In fact, you hijacked this bug report and closed it very prematurely.

Comment 10 René Genz 2021-05-18 21:46:13 UTC
(In reply to Alexei Podtelezhnikov from comment #9)
> ...
> In fact, you hijacked this bug report and closed it very prematurely.

I do not agree. The problem is still there because package xfce4-screensaver's part is not fixed yet, see bug 1957658.
From my point of view there is no need to keep bug 1955993 open because package xscreensaver's part has been fixed very fast by Mamoru TASAKA. Thank you for that.


Note You need to log in before you can comment on or make changes to this bug.