Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1957485 - GNOME 44 compatibility (gnome-shell-extension-openweather)
Summary: GNOME 44 compatibility (gnome-shell-extension-openweather)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell-extension-openweather
Version: 38
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Artem
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-05 20:35 UTC by Hin-Tak Leung
Modified: 2023-04-22 06:26 UTC (History)
5 users (show)

Fixed In Version: gnome-shell-extension-openweather-1-0.49.20210509gitd714eb1.fc35.noarch gnome-shell-extension-openweather-1-0.49.20210509gitd714eb1.fc35 gnome-shell-extension-openweather-1-0.51.20210509gitd714eb1.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-04-19 15:41:36 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Hin-Tak Leung 2021-05-05 20:35:28 UTC
Description of problem:

fedora 34 / gnome 40 starts to check valid shell-version again, and needs this:


--- /usr/share/gnome-shell/extensions/openweather-extension/metadata.json.orig	2021-01-26 12:03:16.000000000 +0000
+++ /usr/share/gnome-shell/extensions/openweather-extension/metadata.json	2021-05-05 21:34:21.017800368 +0100
@@ -2,7 +2,7 @@
 "uuid": "openweather-extension",
 "name": "OpenWeather",
 "description": "Weather extension to display weather information from https://openweathermap.org/ or https://darksky.net for almost all locations in the world.\nFor openweathermap.org, you can either use the extensions default-key or register at https://openweathermap.org/appid and set the appropriate switch in the preferences dialog to \"off\".\nFor Dark Sky you have to register at https://darksky.net/dev/register and get a personal API-key.\n\nSince version 29 this extensions uses coordinates to store the locations and makes the names editable to support multiple weather-providers!\nIf you update from versions prior to 29 to 29 or greater (with darksky.net - support) you have to recreate your locations.",
-"shell-version": [ "3.32", "3.34", "3.36" ],
+"shell-version": [ "3.32", "3.34", "3.36", "40" ],
 "localedir": "/usr/share/locale",
 "url": "https://gitlab.com/jenslody/gnome-shell-extension-openweather",
 "version": "7a9236a"




Version-Release number of selected component (if applicable):
gnome-shell-extension-openweather-1-0.46.20200531git7a9236a.fc34.noarch

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
fails to load

Expected results:
load sucessfully

Additional info:
diff as above.

Comment 1 Fedora Update System 2021-05-13 10:42:09 UTC
FEDORA-2021-fe5888d393 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-fe5888d393

Comment 2 Fedora Update System 2021-05-14 17:50:25 UTC
FEDORA-2021-fe5888d393 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 3 Andre Robatino 2021-11-05 09:19:43 UTC
This bug now exists in F35 with GNOME 41. It works only if I disable extension version validation.

Comment 4 Fedora Update System 2021-11-07 06:50:26 UTC
FEDORA-2021-b5cd2f64a2 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-b5cd2f64a2

Comment 5 Artem 2021-11-07 06:59:53 UTC
@Andre thanks for reporting. Please try new update since i don't have time to test all of this.

Comment 6 Andre Robatino 2021-11-07 09:18:57 UTC
Thanks for update - works now in F35 without disabling extension version validation, karma given.

Comment 7 Fedora Update System 2021-11-08 01:11:43 UTC
FEDORA-2021-b5cd2f64a2 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Andre Robatino 2022-03-23 17:44:00 UTC
This bug now exists in F36 with GNOME 42. It works only if I disable extension version validation.

Comment 9 Fedora Update System 2022-04-23 22:45:43 UTC
FEDORA-2022-e4da74cea2 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-e4da74cea2

Comment 10 Fedora Update System 2022-04-23 22:46:17 UTC
FEDORA-2022-e4da74cea2 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Fedora Update System 2022-04-23 22:47:32 UTC
FEDORA-2022-3fe1fc1845 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-3fe1fc1845

Comment 12 Fedora Update System 2022-04-24 18:43:58 UTC
FEDORA-2022-3fe1fc1845 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-3fe1fc1845`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-3fe1fc1845

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2022-05-07 04:30:33 UTC
FEDORA-2022-3fe1fc1845 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Christoph 2022-05-09 05:37:35 UTC
I can confirm that I can load the extension again and it is visible.
But I can't select any other location.
Than I receive the following:

Mai 09 07:35:07 fedora-testing-vm gjs[3735]: JS ERROR: TypeError: Soup.form_request_new_from_hash is not a function
                                             loadJsonAsync@/usr/share/gnome-shell/extensions/openweather-extension/prefs.js:670:28
                                             wrapper@resource:///org/gnome/gjs/modules/script/_legacy.js:83:27
                                             initWindow/<@/usr/share/gnome-shell/extensions/openweather-extension/prefs.js:206:22
                                             run@resource:///org/gnome/Shell/Extensions/js/dbusService.js:186:20
                                             main@resource:///org/gnome/Shell/Extensions/js/main.js:22:13
                                             run@resource:///org/gnome/gjs/modules/script/package.js:206:19
                                             start@resource:///org/gnome/gjs/modules/script/package.js:190:8
                                             @/usr/share/gnome-shell/org.gnome.Shell.Extensions:1:17

Comment 15 Andre Robatino 2023-04-01 14:44:26 UTC
This bug now exists in F38 with GNOME 44. It works only if I disable extension version validation. (There is also a separate issue where even if I disable version validation, I only see a circular arrow with 3 dots to the right, it never actually loads. Looking at https://gitlab.com/skrewball/openweather/-/issues to see if this is something I need to fix by editing user files or if the package itself needs fixing.)

Comment 16 Andre Robatino 2023-04-01 15:27:42 UTC
Figured it out, see https://gitlab.com/skrewball/openweather/-/issues/74 . Basically, I just edited extension.js to replace

theme.set_custom_theme(St.Settings.get().gtk_icon_theme);

with

theme.set_custom_theme(St.Settings.get().gtk_icon_theme);

to solve the not loading problem, and of course the GNOME 44 compatibility just requires editing metadata.json to replace

"shell-version": ["42", "43"],

with

"shell-version": ["42", "43", "44"],

and after logging out and back in it works without disabling version validation. You probably already know about this, just putting it here for any users looking. Won't bother to file a separate bug.

Comment 17 Andre Robatino 2023-04-01 15:30:27 UTC
Sorry, the replacement line in extension.js should have been

theme.set_theme_name(St.Settings.get().gtk_icon_theme);

Comment 18 Andre Robatino 2023-04-19 15:41:36 UTC
Fixed in https://bodhi.fedoraproject.org/updates/FEDORA-2023-e497b36821 .


Note You need to log in before you can comment on or make changes to this bug.