Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1959270 - Compilation fails when recompiling cloudflare/boringtun
Summary: Compilation fails when recompiling cloudflare/boringtun
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rust
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rust SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-11 06:49 UTC by Andy Grover
Modified: 2021-05-27 00:41 UTC (History)
6 users (show)

Fixed In Version: rust-1.52.1-1.fc32 rust-1.52.1-1.fc34 rust-1.52.1-1.fc33 rust-1.52.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-14 17:51:12 UTC
Type: Bug


Attachments (Terms of Use)

Description Andy Grover 2021-05-11 06:49:30 UTC
Description of problem:
Seeing a compilation error when compiling a crate. It seems to be related to incremental compilation (i.e. doesn't happen if compiling fresh, only if a file is touched then recompiled.

Version-Release number of selected component (if applicable):
rust-1.51.0-3.fc34.x86_64

How reproducible:
always

Steps to Reproduce:
1. git clone https://github.com/cloudflare/boringtun
2. cd boringtun
3. cargo build
4. touch src/main.rs
5. cargo build

Actual results:
recompiles

Expected results:

Compiling boringtun v0.3.0 (/home/agrover/temp/boringtun)
error: could not copy "/home/agrover/temp/boringtun/target/debug/deps/boringtun-d2060d88b0553562.1mbfoibdawt1x325.rcgu.s" to "/home/agrover/temp/boringtun/target/debug/deps/boringtun-d2060d88b0553562.s": No such file or directory (os error 2)

error: failed to remove /home/agrover/temp/boringtun/target/debug/deps/boringtun-d2060d88b0553562.1mbfoibdawt1x325.rcgu.s: No such file or directory (os error 2)

error: aborting due to 2 previous errors

error: could not compile `boringtun`

Additional info:

Hi, just wanted to report this issue here, to make sure it's not a Fedora-specific issue. (I see no mention of it upstream.)

workaround: Disable incremental compilation.

Comment 1 Fabio Valentini 2021-05-11 07:31:14 UTC
You might be interested in the Rust 1.52.1 release notes:
https://blog.rust-lang.org/2021/05/10/Rust-1.52.1.html

TL;DR: There are bugs in incremental compilation mode and it's now disabled by default as of Rust 1.52.1.

Comment 2 Josh Stone 2021-05-11 16:05:41 UTC
(In reply to Fabio Valentini from comment #1)
> TL;DR: There are bugs in incremental compilation mode and it's now disabled
> by default as of Rust 1.52.1.

Right, and these surfaced in 1.52.0 because some verification was added that turned those bugs into internal compiler errors (ICE) rather than silent miscompilations. The bugs were already there though, so it's "interesting" that you're now running into that with 1.51.0.

I built 1.52.1 yesterday, so I'll get that into bodhi today. I'll add this bug in the update -- testing appreciated.

Comment 3 Fedora Update System 2021-05-11 17:00:12 UTC
FEDORA-2021-1e144658cb has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-1e144658cb

Comment 4 Fedora Update System 2021-05-11 17:00:13 UTC
FEDORA-EPEL-2021-130c9b8560 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-130c9b8560

Comment 5 Fedora Update System 2021-05-12 06:13:22 UTC
FEDORA-2021-84c090cf2c has been pushed to the Fedora 32 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-84c090cf2c`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-84c090cf2c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2021-05-12 06:22:51 UTC
FEDORA-EPEL-2021-130c9b8560 has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-130c9b8560

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2021-05-12 06:50:21 UTC
FEDORA-2021-1e144658cb has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-1e144658cb`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-1e144658cb

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2021-05-12 07:05:39 UTC
FEDORA-2021-f8430900fa has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-f8430900fa`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-f8430900fa

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2021-05-14 17:51:12 UTC
FEDORA-2021-84c090cf2c has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Fedora Update System 2021-05-20 01:11:35 UTC
FEDORA-2021-f8430900fa has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Fedora Update System 2021-05-20 01:15:02 UTC
FEDORA-2021-1e144658cb has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Fedora Update System 2021-05-27 00:41:06 UTC
FEDORA-EPEL-2021-130c9b8560 has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.