Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1960335 (CVE-2021-32918) - CVE-2021-32918 prosody: DoS via insufficient memory consumption controls
Summary: CVE-2021-32918 prosody: DoS via insufficient memory consumption controls
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2021-32918
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1960336 1960354
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-13 17:08 UTC by Guilherme de Almeida Suckevicz
Modified: 2021-05-13 20:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-13 20:33:44 UTC
Embargoed:


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2021-05-13 17:08:10 UTC
It was discovered that default settings leave Prosody susceptible to remote unauthenticated denial-of-service (DoS) attacks via memory exhaustion when running under Lua 5.2 or Lua 5.3. Lua 5.2 is the default and recommended Lua version for Prosody 0.11.x series.

The default configuration is susceptible to this issue.
Configurations with stricter settings for stanza size limits, rate limits and garbage collection parameters are at decreased risk from this attack. For more details please review the ‘Mitigation’ section for recommended values.

Reference:
https://prosody.im/security/advisory_20210512/

Comment 1 Guilherme de Almeida Suckevicz 2021-05-13 17:08:24 UTC
Created prosody tracking bugs for this issue:

Affects: fedora-all [bug 1960336]

Comment 2 Robert Scheck 2021-05-13 17:13:16 UTC
Well, this also affects at least EPEL 8

Comment 3 Guilherme de Almeida Suckevicz 2021-05-13 17:21:58 UTC
Created prosody tracking bugs for this issue:

Affects: epel-all [bug 1960354]

Comment 4 Product Security DevOps Team 2021-05-13 20:33:44 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.