Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1963321 - dnf report s "unexpected return value from hdr.sprintf when checking signature" error after downloading package with broken signature
Summary: dnf report s "unexpected return value from hdr.sprintf when checking signatur...
Keywords:
Status: CLOSED DUPLICATE of bug 1963732
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-22 10:16 UTC by Yann Droneaud
Modified: 2021-05-23 19:48 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-23 19:48:21 UTC
Type: Bug


Attachments (Terms of Use)

Description Yann Droneaud 2021-05-22 10:16:24 UTC
After downloading broken packages:

    # dnf distro-sync
    [...]
      package firefox-88.0.1-1.fc33.x86_64 does not verify: Payload SHA256 ALT digest: BAD (Expected 9047f23bef8d4d76d2fa672403e178e0ba2aede33df1d110609b9f21fb673977 != c068a24b1ad9c98f60e4fe4172784dec2147154f0f8e6008067d923257d6575f)
      package kernel-debug-debuginfo-5.12.5-200.fc33.x86_64 does not verify: Payload SHA256 ALT digest: BAD (Expected a1eed29ad88ceb61baf5a1daeacabb3c9e86b55efcf5b81b0b5d547eb57f0bcd != fcc2f78645c573200cf5bf171255bab5f854fdbab588ee4b4f3a870d0289039e)

Further attempts fail with the following python trace:

    # dnf distro-sync
    [...]
    Traceback (most recent call last):
       File "/usr/bin/dnf", line 58, in <module>
        main.user_main(sys.argv[1:], exit_code=True)
      File "/usr/lib/python3.9/site-packages/dnf/cli/main.py", line 201, in user_main
        errcode = main(args)
      File "/usr/lib/python3.9/site-packages/dnf/cli/main.py", line 67, in main
        return _main(base, args, cli_class, option_parser_class)
      File "/usr/lib/python3.9/site-packages/dnf/cli/main.py", line 106, in _main
        return cli_run(cli, base)
      File "/usr/lib/python3.9/site-packages/dnf/cli/main.py", line 130, in cli_run
        ret = resolving(cli, base)
      File "/usr/lib/python3.9/site-packages/dnf/cli/main.py", line 176, in resolving
        base.do_transaction(display=displays)
      File "/usr/lib/python3.9/site-packages/dnf/cli/cli.py", line 238, in do_transaction
        self.gpgsigcheck(install_pkgs)
      File "/usr/lib/python3.9/site-packages/dnf/cli/cli.py", line 278, in gpgsigcheck
        result, errmsg = self._sig_check_pkg(po)
      File "/usr/lib/python3.9/site-packages/dnf/base.py", line 1297, in _sig_check_pkg
        sigresult = dnf.rpm.miscutils.checkSig(ts, po.localPkg())
      File "/usr/lib/python3.9/site-packages/dnf/rpm/miscutils.py", line 90, in checkSig
        raise ValueError('Unexpected return value %r from hdr.sprintf when checking signature.' % siginfo)
    ValueError: Unexpected return value 'RSA/SHA256, Wed 19 May 2021 11:27:32 PM CEST, Key ID 49fd77499570ff31' from hdr.sprintf when checking signature.

Comment 1 Yann Droneaud 2021-05-23 19:48:21 UTC

*** This bug has been marked as a duplicate of bug 1963732 ***


Note You need to log in before you can comment on or make changes to this bug.