Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1964991 - Failed to start PARSEC-encrypted DBus secrets daemon
Summary: Failed to start PARSEC-encrypted DBus secrets daemon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dbus-parsec
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: IoT
TreeView+ depends on / blocked
 
Reported: 2021-05-26 13:37 UTC by Paul Whalen
Modified: 2023-07-24 12:57 UTC (History)
7 users (show)

Fixed In Version: dbus-parsec-0.4.0-1.fc37 dbus-parsec-0.4.0-1.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-10-04 00:17:22 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
full logs (deleted)
2021-05-26 13:39 UTC, Paul Whalen
no flags Details

Description Paul Whalen 2021-05-26 13:37:40 UTC
Description of problem:

During the boot of recent f35 iot nightlies, dbus-parsec shows up as failed in the boot messages:

[FAILED] Failed to start PARSEC-encrypted DBus secrets daemon.
See 'systemctl status dbus-parsec.service' for details.

After the system is booted, the service is running:

● dbus-parsec.service - PARSEC-encrypted DBus secrets daemon
     Loaded: loaded (/usr/lib/systemd/system/dbus-parsec.service; enabled; vend>
     Active: active (running) since Wed 2021-05-26 08:28:42 CDT; 5min ago
   Main PID: 882 (dbus-parsec)
      Tasks: 1 (limit: 4617)
     Memory: 588.0K
        CPU: 15ms
     CGroup: /system.slice/dbus-parsec.service
             └─882 /usr/libexec/dbus-parsec

May 26 08:28:42 fedora systemd[1]: Starting PARSEC-encrypted DBus secrets daemo>
May 26 08:28:42 fedora systemd[1]: Started PARSEC-encrypted DBus secrets daemon.
May 26 08:28:42 fedora dbus-parsec[882]: Running

Version-Release number of selected component (if applicable):
parsec-0.7.0-2.fc35.x86_64
dbus-parsec-0.3.1-3.fc35.x86_64


Additional info:

From the logs:

[root@fedora ~]# journalctl|grep -i parsec
May 26 08:28:31 fedora systemd[1]: Starting Parsec Service...
May 26 08:28:31 fedora systemd[1]: Started Parsec Service.
May 26 08:28:31 fedora audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=parsec comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 26 08:28:31 fedora systemd[1]: Starting PARSEC-encrypted DBus secrets daemon...
May 26 08:28:31 fedora dbus-parsec[738]: Error: DBus(D-Bus error: The name is not activatable (org.freedesktop.DBus.Error.ServiceUnknown))

May 26 08:28:31 fedora systemd[1]: dbus-parsec.service: Main process exited, code=exited, status=1/FAILURE
May 26 08:28:31 fedora systemd[1]: dbus-parsec.service: Failed with result 'exit-code'.
May 26 08:28:31 fedora systemd[1]: Failed to start PARSEC-encrypted DBus secrets daemon.
May 26 08:28:31 fedora audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=dbus-parsec comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
May 26 08:28:42 fedora systemd[1]: dbus-parsec.service: Scheduled restart job, restart counter is at 1.
May 26 08:28:42 fedora systemd[1]: Stopped PARSEC-encrypted DBus secrets daemon.
May 26 08:28:42 fedora audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=dbus-parsec comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 26 08:28:42 fedora audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=dbus-parsec comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 26 08:28:42 fedora systemd[1]: Starting PARSEC-encrypted DBus secrets daemon...
May 26 08:28:42 fedora audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=dbus-parsec comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 26 08:28:42 fedora systemd[1]: Started PARSEC-encrypted DBus secrets daemon.
May 26 08:28:42 fedora NetworkManager[762]: <info>  [1622035722.2082] agent-manager: agent[1553ccb2ee635ce3,:1.18/com.github.puiterwijk.dbus_parsec/0]: agent registered
May 26 08:28:42 fedora dbus-parsec[882]: Running

Comment 1 Paul Whalen 2021-05-26 13:39:38 UTC
Created attachment 1787267 [details]
full logs

Comment 2 Ben Cotton 2021-08-10 13:04:26 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 3 Juan Orti 2022-05-22 09:04:33 UTC
Failing with a different error in F36:

Versions:
parsec-1.0.0-1.fc36.aarch64
dbus-parsec-0.3.1-4.fc35.aarch64

Logs:
[ 1557.474874] dbus-parsec[4598]: Error: ParsecClient(Client(Interface(OpcodeDoesNotExist)))
[ 1557.478042] systemd[1]: dbus-parsec.service: Main process exited, code=exited, status=1/FAILURE
[ 1557.479525] systemd[1]: dbus-parsec.service: Failed with result 'exit-code'.
[ 1557.481293] systemd[1]: Failed to start dbus-parsec.service - PARSEC-encrypted DBus secrets daemon.

Comment 4 Fedora Update System 2022-09-28 15:51:29 UTC
FEDORA-2022-d6365e6c89 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-d6365e6c89

Comment 5 Fedora Update System 2022-09-29 04:39:17 UTC
FEDORA-2022-d6365e6c89 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-d6365e6c89`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-d6365e6c89

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2022-09-29 10:11:36 UTC
FEDORA-2022-9b4f74b3a4 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-9b4f74b3a4

Comment 7 Fedora Update System 2022-09-30 02:06:28 UTC
FEDORA-2022-9b4f74b3a4 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-9b4f74b3a4`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-9b4f74b3a4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2022-10-04 00:17:22 UTC
FEDORA-2022-d6365e6c89 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2022-10-07 15:54:58 UTC
FEDORA-2022-9b4f74b3a4 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Dávid Halász 2023-07-09 19:45:12 UTC
The issue is still present in Fedora 38:

$ journalctl -fu parsec
Jul 09 19:42:31 localhost systemd[1]: Starting parsec.service - Parsec Service...
Jul 09 19:42:31 localhost parsec[804]: Error: Permission denied (os error 13)
Jul 09 19:42:31 localhost systemd[1]: parsec.service: Main process exited, code=exited, status=1/FAILURE
Jul 09 19:42:31 localhost systemd[1]: parsec.service: Failed with result 'exit-code'.
Jul 09 19:42:31 localhost systemd[1]: Failed to start parsec.service - Parsec Service.

Comment 11 Björn Lindström 2023-07-22 19:10:36 UTC
I also see the same thing as Dávid, on:

● fedora-iot:fedora/stable/aarch64/iot
                  Version: 38.20230707.0 (2023-07-07T08:09:28Z)
                   Commit: 4e0ca4635cdfc9b672f82cd77473fad68f046b09d5bf4bf764d9b2cbf8eb4cb1
             GPGSignature: Valid signature by 6A51BBABBA3D5467B6171221809A8D7CEB10B464

which has dbus-parsec-0.4.0-4.fc38.aarch64

Comment 12 Björn Lindström 2023-07-22 19:18:37 UTC
Found that the permission issue was due to somehow the file that we get a permission error on has this ownership:

$ sudo ls -al /var/lib/parsec
total 12
drwxr-x---.  3 parsec  parsec         4096 Mar 29 00:00 .
drwxr-xr-x. 26 root    root           4096 Jul 10 09:22 ..
drwx------.  2 dnsmasq parsec-clients 4096 Mar 29 00:00 mappings

Looking at parsec.spec, it looks like this directory is supposed to be owned by parsec:parsec .

After doing 'sudo chown -R parsec:parsec /var/lib/parsec', the service starts.

Comment 13 Micah Abbott 2023-07-24 12:57:06 UTC
See also https://bugzilla.redhat.com/show_bug.cgi?id=2170957


Note You need to log in before you can comment on or make changes to this bug.