Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1967590 - avc: denied { search } for pid=13640 comm="mdadm" name="dma_heap" dev="devtmpfs" ino=136 scontext=system_u:system_r:mdadm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:dma_device_t:s0 tclass=dir permissive=1
Summary: avc: denied { search } for pid=13640 comm="mdadm" name="dma_heap" dev="dev...
Keywords:
Status: CLOSED DUPLICATE of bug 1965743
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-06-03 12:48 UTC by Bruno Goncalves
Modified: 2021-06-04 19:51 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-04 19:51:39 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Bruno Goncalves 2021-06-03 12:48:32 UTC
Description of problem:
during CKI "swraid/trim" test [1] we hit the following issue:

time->Thu Jun  3 08:29:51 2021
type=AVC msg=audit(1622723391.873:316): avc:  denied  { search } for  pid=13640 comm="mdadm" name="dma_heap" dev="devtmpfs" ino=136 scontext=system_u:system_r:mdadm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:dma_device_t:s0 tclass=dir permissive=1

Version-Release number of selected component (if applicable):
selinux-policy-34.9-1.fc34.noarch

How reproducible:
It seems to be 100% reproducible

Steps to Reproduce:
1.Run the test [1] and check for avc denials


[1] https://gitlab.com/cki-project/kernel-tests/-/tree/main/storage/swraid/trim

Comment 2 Zdenek Pytela 2021-06-04 19:51:39 UTC

*** This bug has been marked as a duplicate of bug 1965743 ***


Note You need to log in before you can comment on or make changes to this bug.