Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1967624 - SELinux is preventing find from read access on the directory dma_heap
Summary: SELinux is preventing find from read access on the directory dma_heap
Keywords:
Status: CLOSED DUPLICATE of bug 1965743
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-06-03 13:38 UTC by Omair Majid
Modified: 2021-06-04 19:52 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-04 19:52:34 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Omair Majid 2021-06-03 13:38:03 UTC
Description of problem:

I am getting this notification. I am not sure what this is. Is this a bug? Has SELinux identified malware?

"""
SELinux is preventing find from read access on the directory dma_heap.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that find should be allowed read access on the dma_heap directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'find' --raw | audit2allow -M my-find
# semodule -X 300 -i my-find.pp

Additional Information:
Source Context                system_u:system_r:system_cronjob_t:s0-s0:c0.c1023
Target Context                system_u:object_r:dma_device_t:s0
Target Objects                dma_heap [ dir ]
Source                        find
Source Path                   find
Port                          <Unknown>
Host                          terminus
Source RPM Packages           
Target RPM Packages           
SELinux Policy RPM            selinux-policy-targeted-34.9-1.fc34.noarch
Local Policy RPM              selinux-policy-targeted-34.9-1.fc34.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     terminus
Platform                      Linux terminus 5.12.8-300.fc34.x86_64 #1 SMP Fri
                              May 28 15:20:54 UTC 2021 x86_64 x86_64
Alert Count                   4
First Seen                    2021-06-02 10:38:07 EDT
Last Seen                     2021-06-03 03:29:18 EDT
Local ID                      7d6f95e9-ccfa-4671-8f74-1e5463dc6103

Raw Audit Messages
type=AVC msg=audit(1622705358.633:2657): avc:  denied  { read } for  pid=224702 comm="find" name="dma_heap" dev="devtmpfs" ino=152 scontext=system_u:system_r:system_cronjob_t:s0-s0:c0.c1023 tcontext=system_u:object_r:dma_device_t:s0 tclass=dir permissive=0


Hash: find,system_cronjob_t,dma_device_t,dir,read
"""


My crontab doesn't have anything:

$ sudo crontab -l
no crontab for root
$ crontab -l
no crontab for omajid



Version-Release number of selected component (if applicable):
libselinux-3.2-1.fc34.x86_64
libselinux-utils-3.2-1.fc34.x86_64
libselinux-devel-3.2-1.fc34.x86_64
python3-libselinux-3.2-1.fc34.x86_64
rpm-plugin-selinux-4.16.1.3-1.fc34.x86_64
flatpak-selinux-1.10.2-3.fc34.noarch
container-selinux-2.162.1-3.fc34.noarch
selinux-policy-34.9-1.fc34.noarch
selinux-policy-targeted-34.9-1.fc34.noarch


How reproducible:

Getting this randomly a few times a day.

Don't know how to reproduce this.

The event at "2021-06-03 03:29:18 EDT" is when I was asleep, so this isn't something manual....

Steps to Reproduce:
1. Don't know. 
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Zdenek Pytela 2021-06-04 19:52:34 UTC

*** This bug has been marked as a duplicate of bug 1965743 ***


Note You need to log in before you can comment on or make changes to this bug.