Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1968053 - SELinux is preventing restorecon from 'open' accesses on the directory /dev/dma_heap.
Summary: SELinux is preventing restorecon from 'open' accesses on the directory /dev/d...
Keywords:
Status: CLOSED DUPLICATE of bug 1965743
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f37c2de3c0e89afec8d0a0ef942...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-06-04 19:33 UTC by Mikhail
Modified: 2021-06-04 19:58 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-04 19:58:58 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Mikhail 2021-06-04 19:33:05 UTC
Description of problem:
SELinux is preventing restorecon from 'open' accesses on the directory /dev/dma_heap.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that restorecon should be allowed open access on the dma_heap directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'restorecon' --raw | audit2allow -M my-restorecon
# semodule -X 300 -i my-restorecon.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:setfiles_t:s0-s0:c0.c102
                              3
Target Context                system_u:object_r:dma_device_t:s0
Target Objects                /dev/dma_heap [ dir ]
Source                        restorecon
Source Path                   restorecon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
SELinux Policy RPM            selinux-policy-targeted-34.9-1.fc35.noarch
Local Policy RPM              selinux-policy-targeted-34.9-1.fc35.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 5.13.0-0.rc3.20210527gitad9f25d338
                              60.28.fc35.x86_64 #1 SMP Thu May 27 16:35:38 UTC
                              2021 x86_64 x86_64
Alert Count                   1
First Seen                    2021-05-29 23:25:50 +05
Last Seen                     2021-05-29 23:25:50 +05
Local ID                      76612f9c-96c8-473f-83ed-5b96c49f3aef

Raw Audit Messages
type=AVC msg=audit(1622312750.442:783): avc:  denied  { open } for  pid=631469 comm="restorecon" path="/dev/dma_heap" dev="devtmpfs" ino=222 scontext=unconfined_u:unconfined_r:setfiles_t:s0-s0:c0.c1023 tcontext=system_u:object_r:dma_device_t:s0 tclass=dir permissive=1


Hash: restorecon,setfiles_t,dma_device_t,dir,open

Version-Release number of selected component:
selinux-policy-targeted-34.9-1.fc35.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.14.0
hashmarkername: setroubleshoot
kernel:         5.13.0-0.rc3.20210527gitad9f25d33860.28.fc35.x86_64
type:           libreport

Comment 1 Zdenek Pytela 2021-06-04 19:58:58 UTC

*** This bug has been marked as a duplicate of bug 1965743 ***


Note You need to log in before you can comment on or make changes to this bug.