Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1968819 - F35FailsToInstall: python3-imath
Summary: F35FailsToInstall: python3-imath
Alias: None
Product: Fedora
Classification: Fedora
Component: imath
Version: rawhide
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact:
Depends On:
Blocks: PYTHON3.10 F35FailsToInstall
TreeView+ depends on / blocked
Reported: 2021-06-07 23:09 UTC by Miro Hrončok
Modified: 2021-06-08 13:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2021-06-08 13:42:15 UTC
Type: ---

Attachments (Terms of Use)

Description Miro Hrončok 2021-06-07 23:09:55 UTC

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (imath) Fails To Install in Fedora 35:

can't install python3-imath:
  - nothing provides needed by python3-imath-3.0.2-3.fc35.x86_64
  - nothing provides python(abi) = 3.9 needed by python3-imath-3.0.2-3.fc35.x86_64
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

If you don't react accordingly to the policy for FTBFS/FTI bugs (, your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags:


Comment 1 Miro Hrončok 2021-06-07 23:27:31 UTC
This bugzilla is likely a fallout from the Python 3.10 rebuild.

If your package (or some of the dependencies it has) failed to rebuild during the Python 3.10 rebuild, they now fail to install. To fix this, packages need to be rebuilt in Rawhide.

We will slowly triage the bugzillas, but we'd appreciate your help.

If you know this is blocked by an existing reported build failure or another package not yet rebuilt with Python 3.10, please mark it as such by using the "Depends On"/"Blocks" bugzilla fields. That will help us determine what failures to prioritize.

Thank you and sorry for the inconvenience. Let me know if you need any help.

Comment 2 Richard Shaw 2021-06-08 11:59:42 UTC
This one is pretty straightforward. The python version is in the library names as "3_9". Is there a python macro that can automate this?

Comment 3 Richard Shaw 2021-06-08 12:21:58 UTC
I tried borrowing from "rpm --showrc" but rpmbuild seems to choke on it:

%global pyver_under %(%{python3} -Esc "import sys; sys.stdout.write('{0.major}_{0.minor}'.format(sys.version_info))")

Comment 4 Miro Hrončok 2021-06-08 12:31:13 UTC
choke how?

Comment 5 Richard Shaw 2021-06-08 12:36:07 UTC
$ rpmbuild -bs imath.spec
error: line 81: unclosed macro or bad line continuation

$ rpm --eval "%(%{python3} -Esc "import sys; sys.stdout.write('{0.major}_{0.minor}'.format(sys.version_info))")"
-bash: syntax error near unexpected token `'{0.major}_{0.minor}'.format'

Comment 6 Miro Hrončok 2021-06-08 12:42:14 UTC
The second one appears to be shell quotes problem.

I have:

$ git diff
diff --git a/imath.spec b/imath.spec
index 9c7c133..365bd1c 100644
--- a/imath.spec
+++ b/imath.spec
@@ -1,5 +1,6 @@
 %global srcname Imath
 %global sover 28
+%global pyver_under %(%{python3} -Esc "import sys; sys.stdout.write('{0.major}_{0.minor}'.format(sys.version_info))")
 Name:           imath
 Version:        3.0.2
@@ -77,7 +78,7 @@ rm -rf html/.{doctrees,buildinfo}
 %files -n python3-%{name}
@@ -89,7 +90,7 @@ rm -rf html/.{doctrees,buildinfo}

Comment 7 Richard Shaw 2021-06-08 12:47:56 UTC
Hah... some ")" worked into the substitution in %files instead of "}". That'll bite you every time.

Comment 8 Miro Hrončok 2021-06-08 13:42:15 UTC

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 35.

Thanks for taking care of it!

Note You need to log in before you can comment on or make changes to this bug.