Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1969658 - SELinux is preventing updatedb from 'search' accesses on the directory dma_heap.
Summary: SELinux is preventing updatedb from 'search' accesses on the directory dma_heap.
Keywords:
Status: CLOSED DUPLICATE of bug 1965743
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 34
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4270f030eee86cc102a2250e38e...
: 1970543 1970550 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-06-08 20:48 UTC by Michael
Modified: 2021-06-10 16:56 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-08 21:50:29 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Michael 2021-06-08 20:48:49 UTC
Description of problem:
Running updatedb
SELinux is preventing updatedb from 'search' accesses on the directory dma_heap.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that updatedb should be allowed search access on the dma_heap directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'updatedb' --raw | audit2allow -M my-updatedb
# semodule -X 300 -i my-updatedb.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Context                system_u:object_r:dma_device_t:s0
Target Objects                dma_heap [ dir ]
Source                        updatedb
Source Path                   updatedb
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
SELinux Policy RPM            selinux-policy-targeted-34.9-1.fc34.noarch
Local Policy RPM              selinux-policy-targeted-34.9-1.fc34.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.11.21-300.fc34.x86_64 #1 SMP Fri
                              May 14 17:43:38 UTC 2021 x86_64 x86_64
Alert Count                   1
First Seen                    2021-06-08 22:48:06 CEST
Last Seen                     2021-06-08 22:48:06 CEST
Local ID                      79000aa0-140c-4836-9f24-73bcfd1b001d

Raw Audit Messages
type=AVC msg=audit(1623185286.619:3176): avc:  denied  { search } for  pid=306919 comm="updatedb" name="dma_heap" dev="devtmpfs" ino=138 scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=system_u:object_r:dma_device_t:s0 tclass=dir permissive=0


Hash: updatedb,unconfined_t,dma_device_t,dir,search

Version-Release number of selected component:
selinux-policy-targeted-34.9-1.fc34.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.14.0
hashmarkername: setroubleshoot
kernel:         5.11.21-300.fc34.x86_64
type:           libreport

Comment 1 Michael 2021-06-08 21:40:09 UTC
Similar problem has been detected:

Running updatedb

hashmarkername: setroubleshoot
kernel:         5.12.9-300.fc34.x86_64
package:        selinux-policy-targeted-34.9-1.fc34.noarch
reason:         SELinux is preventing updatedb from 'search' accesses on the directory dma_heap.
type:           libreport

Comment 2 Zdenek Pytela 2021-06-08 21:50:29 UTC

*** This bug has been marked as a duplicate of bug 1965743 ***

Comment 3 valsu 2021-06-10 16:39:36 UTC
*** Bug 1970543 has been marked as a duplicate of this bug. ***

Comment 4 valsu 2021-06-10 16:56:35 UTC
*** Bug 1970550 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.