Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1971316 - SELinux is preventing find from 'read' accesses on the directory dma_heap.
Summary: SELinux is preventing find from 'read' accesses on the directory dma_heap.
Keywords:
Status: CLOSED DUPLICATE of bug 1965743
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 34
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:485aa01fcea3102b1d199f634c3...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-06-13 15:05 UTC by Christopher Archer
Modified: 2021-06-15 20:54 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-15 20:54:57 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Christopher Archer 2021-06-13 15:05:06 UTC
Description of problem:
SELinux is preventing find from 'read' accesses on the directory dma_heap.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that find should be allowed read access on the dma_heap directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'find' --raw | audit2allow -M my-find
# semodule -X 300 -i my-find.pp

Additional Information:
Source Context                system_u:system_r:system_cronjob_t:s0-s0:c0.c1023
Target Context                system_u:object_r:dma_device_t:s0
Target Objects                dma_heap [ dir ]
Source                        find
Source Path                   find
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
SELinux Policy RPM            selinux-policy-targeted-34.11-1.fc34.noarch
Local Policy RPM              selinux-policy-targeted-34.11-1.fc34.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.12.9-300.fc34.x86_64 #1 SMP Thu
                              Jun 3 13:51:40 UTC 2021 x86_64 x86_64
Alert Count                   26
First Seen                    2021-06-01 03:52:02 EDT
Last Seen                     2021-06-13 03:41:45 EDT
Local ID                      05e1666b-d7d5-48da-891e-25c04c05e56f

Raw Audit Messages
type=AVC msg=audit(1623570105.823:3563): avc:  denied  { read } for  pid=1614633 comm="find" name="dma_heap" dev="devtmpfs" ino=142 scontext=system_u:system_r:system_cronjob_t:s0-s0:c0.c1023 tcontext=system_u:object_r:dma_device_t:s0 tclass=dir permissive=0


Hash: find,system_cronjob_t,dma_device_t,dir,read

Version-Release number of selected component:
selinux-policy-targeted-34.11-1.fc34.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.15.2
hashmarkername: setroubleshoot
kernel:         5.12.9-300.fc34.x86_64
type:           libreport

Potential duplicate: bug 1968571

Comment 1 Zdenek Pytela 2021-06-15 20:54:57 UTC

*** This bug has been marked as a duplicate of bug 1965743 ***


Note You need to log in before you can comment on or make changes to this bug.