Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1973412 - SELinux is preventing mdadm from 'search' accesses on the katalog dma_heap.
Summary: SELinux is preventing mdadm from 'search' accesses on the katalog dma_heap.
Keywords:
Status: CLOSED DUPLICATE of bug 1965743
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 33
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d0d59fc6de91ee002457f201a1d...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-06-17 18:58 UTC by Leszek Matok
Modified: 2021-06-18 19:10 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-18 19:10:14 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Leszek Matok 2021-06-17 18:58:00 UTC
Description of problem:
F33 update pulled selinux-policy-3.14.6-38.fc33.noarch (from selinux-policy-3.14.6-37.fc33.noarch)

After a reboot, two alerts came up for mdadm accessing (search, read) a "directory" of "dma_heap".
SELinux is preventing mdadm from 'search' accesses on the katalog dma_heap.

*****  Plugin catchall (100. confidence) suggests   **************************

Aby mdadm powinno mieć domyślnie search dostęp do dma_heap directory.
Then proszę to zgłosić jako błąd.
Można utworzyć lokalny moduł polityki, aby umożliwić ten dostęp.
Do
można tymczasowo zezwolić na ten dostęp wykonując polecenia:
# ausearch -c 'mdadm' --raw | audit2allow -M my-mdadm
# semodule -X 300 -i my-mdadm.pp

Additional Information:
Source Context                system_u:system_r:mdadm_t:s0
Target Context                system_u:object_r:dma_device_t:s0
Target Objects                dma_heap [ dir ]
Source                        mdadm
Source Path                   mdadm
Port                          <Nieznane>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
SELinux Policy RPM            <Nieznane>
Local Policy RPM              selinux-policy-targeted-3.14.6-38.fc33.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.12.11-200.fc33.x86_64 #1 SMP Wed
                              Jun 16 16:10:53 UTC 2021 x86_64 x86_64
Alert Count                   3
First Seen                    2021-06-17 17:19:33 CEST
Last Seen                     2021-06-17 20:25:52 CEST
Local ID                      093ce7ce-c170-4331-bea0-d9651fc20694

Raw Audit Messages
type=AVC msg=audit(1623954352.156:155): avc:  denied  { search } for  pid=1009 comm="mdadm" name="dma_heap" dev="devtmpfs" ino=148 scontext=system_u:system_r:mdadm_t:s0 tcontext=system_u:object_r:dma_device_t:s0 tclass=dir permissive=0


Hash: mdadm,mdadm_t,dma_device_t,dir,search


Additional info:
component:      selinux-policy
reporter:       libreport-2.14.0
hashmarkername: setroubleshoot
kernel:         5.12.11-200.fc33.x86_64
type:           libreport

Comment 2 Zdenek Pytela 2021-06-18 19:10:14 UTC

*** This bug has been marked as a duplicate of bug 1965743 ***


Note You need to log in before you can comment on or make changes to this bug.