Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1973480 - SELinux is preventing /usr/bin/find from 'read' accesses on the directory dma_heap.
Summary: SELinux is preventing /usr/bin/find from 'read' accesses on the directory dma...
Keywords:
Status: CLOSED DUPLICATE of bug 1965743
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 33
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:485aa01fcea3102b1d199f634c3...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-06-17 23:00 UTC by Michael Setzer II
Modified: 2021-06-18 19:10 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-18 19:10:00 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Michael Setzer II 2021-06-17 23:00:12 UTC
Description of problem:
Shows up in SELinux Troubleshooter?
SELinux is preventing /usr/bin/find from 'read' accesses on the directory dma_heap.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that find should be allowed read access on the dma_heap directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'find' --raw | audit2allow -M my-find
# semodule -X 300 -i my-find.pp

Additional Information:
Source Context                system_u:system_r:system_cronjob_t:s0-s0:c0.c1023
Target Context                system_u:object_r:dma_device_t:s0
Target Objects                dma_heap [ dir ]
Source                        find
Source Path                   /usr/bin/find
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           findutils-4.7.0-7.fc33.x86_64
Target RPM Packages           
SELinux Policy RPM            selinux-policy-targeted-3.14.6-38.fc33.noarch
Local Policy RPM              selinux-policy-targeted-3.14.6-38.fc33.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 5.12.10-200.fc33.x86_64 #1 SMP Thu
                              Jun 10 14:19:48 UTC 2021 x86_64 x86_64
Alert Count                   4
First Seen                    2021-06-18 03:33:11 ChST
Last Seen                     2021-06-18 03:33:22 ChST
Local ID                      521fd227-2372-4a2f-bedf-68f5075a165e

Raw Audit Messages
type=AVC msg=audit(1623951202.802:1264): avc:  denied  { read } for  pid=327635 comm="find" name="dma_heap" dev="devtmpfs" ino=130 scontext=system_u:system_r:system_cronjob_t:s0-s0:c0.c1023 tcontext=system_u:object_r:dma_device_t:s0 tclass=dir permissive=1


type=AVC msg=audit(1623951202.802:1264): avc:  denied  { open } for  pid=327635 comm="find" path="/dev/dma_heap" dev="devtmpfs" ino=130 scontext=system_u:system_r:system_cronjob_t:s0-s0:c0.c1023 tcontext=system_u:object_r:dma_device_t:s0 tclass=dir permissive=1


type=SYSCALL msg=audit(1623951202.802:1264): arch=x86_64 syscall=openat success=yes exit=ENXIO a0=5 a1=55ef9615c2b0 a2=b0900 a3=0 items=1 ppid=327634 pid=327635 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=find exe=/usr/bin/find subj=system_u:system_r:system_cronjob_t:s0-s0:c0.c1023 key=(null)

type=CWD msg=audit(1623951202.802:1264): cwd=/

type=PATH msg=audit(1623951202.802:1264): item=0 name=dma_heap inode=130 dev=00:05 mode=040755 ouid=0 ogid=0 rdev=00:00 obj=system_u:object_r:dma_device_t:s0 nametype=NORMAL cap_fp=0 cap_fi=0 cap_fe=0 cap_fver=0 cap_frootid=0

Hash: find,system_cronjob_t,dma_device_t,dir,read

Version-Release number of selected component:
selinux-policy-targeted-3.14.6-38.fc33.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.14.0
hashmarkername: setroubleshoot
kernel:         5.12.10-200.fc33.x86_64
type:           libreport

Potential duplicate: bug 1971316

Comment 1 Zdenek Pytela 2021-06-18 19:10:00 UTC

*** This bug has been marked as a duplicate of bug 1965743 ***


Note You need to log in before you can comment on or make changes to this bug.