Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1978361 - [abrt] ibus-typing-booster: module(): itb_emoji.py:44:<module>:ModuleNotFoundError: No module named 'packaging'
Summary: [abrt] ibus-typing-booster: module(): itb_emoji.py:44:<module>:ModuleNotFound...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-typing-booster
Version: 34
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mike FABIAN
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:fbc5bed4b30ee39d014d4f9e9a4...
: 1978520 1978738 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-07-01 16:17 UTC by Guy Streeter
Modified: 2021-07-15 01:04 UTC (History)
6 users (show)

Fixed In Version: ibus-typing-booster-2.11.5-2.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-15 01:04:29 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: backtrace (deleted)
2021-07-01 16:17 UTC, Guy Streeter
no flags Details
File: cpuinfo (deleted)
2021-07-01 16:17 UTC, Guy Streeter
no flags Details
File: environ (deleted)
2021-07-01 16:17 UTC, Guy Streeter
no flags Details
File: mountinfo (deleted)
2021-07-01 16:17 UTC, Guy Streeter
no flags Details
File: namespaces (deleted)
2021-07-01 16:17 UTC, Guy Streeter
no flags Details
File: open_fds (deleted)
2021-07-01 16:17 UTC, Guy Streeter
no flags Details

Description Guy Streeter 2021-07-01 16:17:35 UTC
Version-Release number of selected component:
ibus-typing-booster-2.11.5-1.fc34

Additional info:
reporter:       libreport-2.15.2
cgroup:         0::/user.slice/user-1001.slice/user/session.slice/org.gnome.Shell
cmdline:        /usr/bin/python3 /usr/share/ibus-typing-booster/engine/main.py --ibus
crash_function: module
exception_type: ModuleNotFoundError
executable:     /usr/share/ibus-typing-booster/engine/main.py
interpreter:    python3-3.9.5-2.fc34.x86_64
kernel:         5.12.13-300.fc34.x86_64
runlevel:       N 5
type:           Python3
uid:            1001

Truncated backtrace:
#1 [/usr/share/ibus-typing-booster/engine/itb_emoji.py:44] <module>
#2 [/usr/share/ibus-typing-booster/engine/hunspell_table.py:51] <module>
#3 [/usr/share/ibus-typing-booster/engine/factory.py:33] <module>
#4 [/usr/share/ibus-typing-booster/engine/main.py:128] <module>

Comment 1 Guy Streeter 2021-07-01 16:17:38 UTC
Created attachment 1796863 [details]
File: backtrace

Comment 2 Guy Streeter 2021-07-01 16:17:39 UTC
Created attachment 1796864 [details]
File: cpuinfo

Comment 3 Guy Streeter 2021-07-01 16:17:40 UTC
Created attachment 1796865 [details]
File: environ

Comment 4 Guy Streeter 2021-07-01 16:17:42 UTC
Created attachment 1796866 [details]
File: mountinfo

Comment 5 Guy Streeter 2021-07-01 16:17:43 UTC
Created attachment 1796867 [details]
File: namespaces

Comment 6 Guy Streeter 2021-07-01 16:17:44 UTC
Created attachment 1796868 [details]
File: open_fds

Comment 7 Nirmal Pathak 2021-07-02 04:29:39 UTC
*** Bug 1978520 has been marked as a duplicate of this bug. ***

Comment 8 Pavel Mentsiukov 2021-07-02 15:43:28 UTC
*** Bug 1978738 has been marked as a duplicate of this bug. ***

Comment 9 Mike FABIAN 2021-07-07 17:01:59 UTC
Quick workaround:

dnf install python3-packaging

I'll add this to the Requires in the .spec file tomorrow.

Comment 10 Fedora Update System 2021-07-08 10:39:16 UTC
FEDORA-2021-d3ba1c0d71 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-d3ba1c0d71

Comment 11 Fedora Update System 2021-07-09 01:52:34 UTC
FEDORA-2021-d3ba1c0d71 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-d3ba1c0d71`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-d3ba1c0d71

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2021-07-15 01:04:29 UTC
FEDORA-2021-d3ba1c0d71 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.