Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1981733 - python3-saml: FTBFS in Fedora rawhide
Summary: python3-saml: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python3-saml
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Callaghan
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: PYTHON3.10 F35FTBFS
TreeView+ depends on / blocked
 
Reported: 2021-07-13 08:56 UTC by Tomáš Hrnčiar
Modified: 2021-08-08 10:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-08 10:31:48 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-07-13 08:56:11 UTC
Description of problem:
Package python3-saml fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
1.9.0-5.fc35

Steps to Reproduce:
koji build --scratch f35 python3-saml-1.9.0-5.fc35.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python3-saml

Comment 1 Fedora Release Engineering 2021-08-01 04:23:27 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 35.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-09-07).

A week before the mass branching of Fedora 36 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 34 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-36/f-36-key-tasks.html

Comment 2 Dan Callaghan 2021-08-08 09:55:29 UTC
Failure is due to a bunch of test failures like this:


======================================================================
FAIL: testIsInValidAudience (tests.src.OneLogin.saml2_tests.response_test.OneLogin_Saml2_Response_Test)
Tests the is_valid method of the OneLogin_Saml2_Response class
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/python3-saml-1.9.0/tests/src/OneLogin/saml2_tests/response_test.py", line 1037, in testIsInValidAudience
    self.assertIn('is not a valid audience for this Response', response_2.get_error())
AssertionError: 'is not a valid audience for this Response' not found in 'Could not validate timestamp: expired. Check system clock.'
[...]


Upstream issue: https://github.com/onelogin/python3-saml/issues/271
Upstream PR: https://github.com/onelogin/python3-saml/pull/269
Fix is included in upstream release 1.11.0 (bug 1916534).


Note You need to log in before you can comment on or make changes to this bug.