Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1986222 - [RFE] Please turn on SimpleDRM driver
Summary: [RFE] Please turn on SimpleDRM driver
Keywords:
Status: CLOSED DUPLICATE of bug 2022385
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARMTracker IoT WaylandRelated KDEWaylandRelated
TreeView+ depends on / blocked
 
Reported: 2021-07-27 01:02 UTC by Neal Gompa
Modified: 2021-12-23 11:44 UTC (History)
27 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1986223 (view as bug list)
Environment:
Last Closed: 2021-12-23 11:44:17 UTC
Type: Enhancement
Embargoed:


Attachments (Terms of Use)

Description Neal Gompa 2021-07-27 01:02:51 UTC
Description of problem:
Linux 5.14 introduces the new SimpleDRM driver as a generic fallback driver that supports KMS. GNOME Wayland does not support non-KMS graphics for rendering, and KDE Plasma's non-KMS (fbdev) rendering mode pretty much does not work. This driver makes it possible for desktop environments to *always* expect KMS to work, even if a native driver isn't available, which makes it simpler to support Wayland.

Please enable SimpleDRM so that it becomes achievable to use Wayland for "basic graphics mode" fallback configurations.

Version-Release number of selected component (if applicable):
5.14.0-0.rc3.29.fc35

Additional info:
The lack of this driver led to bug 1952431 happening during Fedora Linux 34's development and I would really like SimpleDRM to be enabled so I can make more progress on solidifying Wayland support and remove hacks to disable Wayland in "basic graphics mode".

Comment 1 Peter Robinson 2021-07-28 12:45:05 UTC
It's not possible to do this as yet. We're working towards getting rid of FB support altogether, as it's unmaintained and obsolete upstream, there's missing pieces here that conflicts with efifb/vesafb/simplefb and other platforms which kills off consoles.

This enhancement gets us the next step there, it's due to land in 5.15:
https://lists.freedesktop.org/archives/dri-devel/2021-June/312847.html

But that doesn't actually get rid of fbcon as there's no upstream dmscon/kmscon to allow us to remove all of it, that's being worked upon now.

Comment 2 Neal Gompa 2021-07-28 13:03:30 UTC
That mailing list post mentions EFI targets only, what about non-EFI targets for AArch64, armv7hl, POWER, and s390x?

Comment 3 Peter Robinson 2021-07-28 14:17:36 UTC
(In reply to Neal Gompa from comment #2)
> That mailing list post mentions EFI targets only, what about non-EFI targets
> for AArch64, armv7hl, POWER, and s390x?

We're reviewing all. For Fedora use cases all arm, both aarch64/armv7hl are UEFI as of Fedora 34.

In the case of Z/s390x there's no inbuilt graphical console, only serial but we will need to look at how this affects VNC/Virt (not sure it does).

In the case of supported POWER platforms (POWER8 and later) there's no graphical console on the server platforms and early console support on Workstation like Talos2 isn't actually supported at all ATM, basically it's serial output until the desktop loads. I've reached out to some of those people to find out if there's plans around that. Ultimately if their firmware sets up the early console correctly the simpledrm stuff should eventually "just work"

Comment 4 Javier Martinez Canillas 2021-12-23 11:44:17 UTC

*** This bug has been marked as a duplicate of bug 2022385 ***


Note You need to log in before you can comment on or make changes to this bug.