Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1996443 - F35FailsToInstall: mrpt-libs
Summary: F35FailsToInstall: mrpt-libs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mrpt
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rich Mattes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F35BetaFreezeException F35FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2021-08-22 17:45 UTC by Miro Hrončok
Modified: 2021-09-21 03:34 UTC (History)
7 users (show)

Fixed In Version: mrpt-1.4.0-28.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-16 23:54:32 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2021-08-22 17:45:53 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (mrpt) Fails To Install in Fedora 35:

can't install mrpt-libs:
  - nothing provides libpcl_common.so.1.11()(64bit) needed by mrpt-libs-1.4.0-27.fc35.x86_64
  - nothing provides libpcl_features.so.1.11()(64bit) needed by mrpt-libs-1.4.0-27.fc35.x86_64
  - nothing provides libpcl_filters.so.1.11()(64bit) needed by mrpt-libs-1.4.0-27.fc35.x86_64
  - nothing provides libpcl_search.so.1.11()(64bit) needed by mrpt-libs-1.4.0-27.fc35.x86_64
  - nothing provides libpcl_segmentation.so.1.11()(64bit) needed by mrpt-libs-1.4.0-27.fc35.x86_64
  - nothing provides libpcl_io.so.1.11()(64bit) needed by mrpt-libs-1.4.0-27.fc35.x86_64
  - nothing provides libpcl_visualization.so.1.11()(64bit) needed by mrpt-libs-1.4.0-27.fc35.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2021-08-30 17:40:30 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 2 Fedora Update System 2021-09-03 01:41:33 UTC
FEDORA-2021-0dd4607177 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-0dd4607177

Comment 3 Fedora Update System 2021-09-03 15:25:23 UTC
FEDORA-2021-0dd4607177 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-0dd4607177`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-0dd4607177

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Blocker Bugs Application 2021-09-11 18:46:17 UTC
Proposed as a Freeze Exception for 35-beta by Fedora user kevin using the blocker tracking app because:

 This plus rhbz#1991866 are needed to get the robotics lab to compose. 

It would be great to have it for beta.

Comment 5 Lukas Ruzicka 2021-09-13 07:14:42 UTC
I can confirm that this package can be installed with the latest updates.

Comment 6 Fedora Update System 2021-09-16 23:54:32 UTC
FEDORA-2021-0dd4607177 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.