Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1996613 - [abrt] Zim: draw_strikethrough(): python3.9 killed by SIGFPE
Summary: [abrt] Zim: draw_strikethrough(): python3.9 killed by SIGFPE
Keywords:
Status: CLOSED DUPLICATE of bug 1994982
Alias: None
Product: Fedora
Classification: Fedora
Component: Zim
Version: 34
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Robin Lee
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:f05c7912932220e07c4fb4c1d0a...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-08-23 10:19 UTC by Daniel Horák
Modified: 2021-08-23 11:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-23 11:40:58 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: backtrace (deleted)
2021-08-23 10:19 UTC, Daniel Horák
no flags Details
File: core_backtrace (deleted)
2021-08-23 10:19 UTC, Daniel Horák
no flags Details
File: cpuinfo (deleted)
2021-08-23 10:19 UTC, Daniel Horák
no flags Details
File: dso_list (deleted)
2021-08-23 10:19 UTC, Daniel Horák
no flags Details
File: environ (deleted)
2021-08-23 10:19 UTC, Daniel Horák
no flags Details
File: limits (deleted)
2021-08-23 10:19 UTC, Daniel Horák
no flags Details
File: maps (deleted)
2021-08-23 10:19 UTC, Daniel Horák
no flags Details
File: open_fds (deleted)
2021-08-23 10:19 UTC, Daniel Horák
no flags Details
File: proc_pid_status (deleted)
2021-08-23 10:19 UTC, Daniel Horák
no flags Details

Description Daniel Horák 2021-08-23 10:19:03 UTC
Description of problem:
I just tried to launch ZIM and it crashed.

Version-Release number of selected component:
Zim-0.73.5-1.fc34

Additional info:
reporter:       libreport-2.15.2
backtrace_rating: 4
cgroup:         0::/user.slice/user-1000.slice/session-2.scope
cmdline:        /usr/bin/python3 /usr/bin/zim
crash_function: draw_strikethrough
executable:     /usr/bin/python3.9
journald_cursor: s=be082c7b84d44e54aa950fddda3256dd;i=122794;b=cab6a3c2bae743b8895b7826f5f6e927;m=4320c5635;t=5ca36bf10a686;x=1a6d7a63ec274dae
kernel:         5.13.12-200.fc34.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 draw_strikethrough at ../pango/pango-renderer.c:288
 #1 handle_line_state_change at ../pango/pango-renderer.c:341
 #2 pango_renderer_part_changed at ../pango/pango-renderer.c:1440
 #3 pango_renderer_set_alpha at ../pango/pango-renderer.c:1381
 #4 pango_renderer_default_prepare_run at ../pango/pango-renderer.c:1550
 #5 gtk_text_renderer_prepare_run at /usr/src/debug/gtk3-3.24.30-1.fc34.x86_64/gtk/gtktextdisplay.c:182
 #6 pango_renderer_prepare_run at ../pango/pango-renderer.c:1461
 #7 pango_renderer_draw_layout_line at ../pango/pango-renderer.c:620
 #8 render_para at /usr/src/debug/gtk3-3.24.30-1.fc34.x86_64/gtk/gtktextdisplay.c:705
 #9 gtk_text_layout_draw at /usr/src/debug/gtk3-3.24.30-1.fc34.x86_64/gtk/gtktextdisplay.c:942

Comment 1 Daniel Horák 2021-08-23 10:19:07 UTC
Created attachment 1816809 [details]
File: backtrace

Comment 2 Daniel Horák 2021-08-23 10:19:09 UTC
Created attachment 1816810 [details]
File: core_backtrace

Comment 3 Daniel Horák 2021-08-23 10:19:10 UTC
Created attachment 1816811 [details]
File: cpuinfo

Comment 4 Daniel Horák 2021-08-23 10:19:11 UTC
Created attachment 1816812 [details]
File: dso_list

Comment 5 Daniel Horák 2021-08-23 10:19:13 UTC
Created attachment 1816813 [details]
File: environ

Comment 6 Daniel Horák 2021-08-23 10:19:14 UTC
Created attachment 1816814 [details]
File: limits

Comment 7 Daniel Horák 2021-08-23 10:19:16 UTC
Created attachment 1816815 [details]
File: maps

Comment 8 Daniel Horák 2021-08-23 10:19:18 UTC
Created attachment 1816816 [details]
File: open_fds

Comment 9 Daniel Horák 2021-08-23 10:19:19 UTC
Created attachment 1816817 [details]
File: proc_pid_status

Comment 10 Robin Lee 2021-08-23 11:40:58 UTC

*** This bug has been marked as a duplicate of bug 1994982 ***


Note You need to log in before you can comment on or make changes to this bug.