Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1999447 - [F36FTBFS]: fftw fails to build from source in Fedora Rawhide
Summary: [F36FTBFS]: fftw fails to build from source in Fedora Rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: fftw
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F38FTBFS F39FTBFS 1936597 F36FTBFS F37FTBFS
TreeView+ depends on / blocked
 
Reported: 2021-08-31 08:04 UTC by Ondrej Dubaj
Modified: 2023-09-18 04:25 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-03-30 14:57:21 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Ondrej Dubaj 2021-08-31 08:04:44 UTC
Your package fails to build with the newest autoconf-2.71, which was part of a recent wide Fedora change. More information about Fedora autoconf Change available here: https://fedoraproject.org/wiki/Changes/Autoconf_271#How_To_Test. The easiest way to reproduce the problem is to execute a fedora scratch-build on your package. Thank you for cooperation!

Comment 1 Ben Cotton 2022-02-08 21:41:55 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 36 development cycle.
Changing version to 36.

Comment 2 Fedora Release Engineering 2022-12-25 04:22:07 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 37.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-10-26).

A week before the mass branching of Fedora 38 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 36 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-38/f-38-key-tasks.html

Comment 3 Fedora Release Engineering 2023-01-01 04:22:08 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 37.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-10-26).

A week before the mass branching of Fedora 38 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 36 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-38/f-38-key-tasks.html

Comment 4 Fedora Release Engineering 2023-01-22 04:22:12 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 37.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-10-26).

A week before the mass branching of Fedora 38 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 36 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-38/f-38-key-tasks.html

Comment 5 Trent Piepho 2023-03-27 06:27:32 UTC
I have had a PR to fix this package, which has been outstanding since November 2022.  Is there no one who has the authority to act or will let me act to fix it?

Comment 6 David Cantrell 2023-03-27 12:04:09 UTC
I can't merge your PR due to conflicts, but I will take care of it manually today.

Comment 7 David Cantrell 2023-03-27 17:50:43 UTC
I reverted my changes.  Rebase your PR and update everything so it applies.  Adjust the release numbers and update the date stamps in the %changelog entries so they are in chronological order.  I can merge after that.

Comment 8 David Cantrell 2023-03-30 14:57:21 UTC
I merged your PR for rawhide and that built fine.  I tried to bring that to Fedora 38 to do an update, but i686 again fails.  Unless you absolutely need it for Fedora 38, I am inclined to just leave this as-is and Fedora 39 forward will carry your updates.

Comment 9 Trent Piepho 2023-03-30 18:26:52 UTC
Is it the case that without my change the i686 arch builds and tests for *Fedora 38* correctly?  I don't see how my changes could possibly affect i686 in that way.  Everything seems to point to it being an issue with openmpi, not fftw, and i686+openmpi should be broken now on F38.

I personally don't need it in F38.  I can just point people to my COPR repo anyway.  But, it's a pretty massive speed-up on ARMv8, which is becoming a lot more popular.

Comment 10 David Cantrell 2023-03-30 19:14:08 UTC
Yes, I should have clarified.  The problem is with openmpi on i686 on F38.  Glad the improvements are helping on ARMv8.  I will just leave the F38 branch as-is.

Comment 11 Red Hat Bugzilla 2023-09-18 04:25:37 UTC
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 120 days


Note You need to log in before you can comment on or make changes to this bug.